Internet Key Exchange (IKE lub IKE2) – protokół służący do zestawienia bezpiecznego skojarzenia SA () pomiędzy dwoma hostami, zwłaszcza w protokole IPsec.
Nawiązanie bezpiecznej sesji IKE przebiega w dwóch fazach: Faza 1 – ustanowienia bezpiecznego, uwierzytelnionego kanału komunikacji. Strony przy użyciu protokołu Diffiego-Hellmana ustanawiają wspólny sekretny klucz/hasło wykorzystywany dalej do szyfrowana komunikacji IKE w fazie 2. Faza 2 – korzystając z bezpiecznego kanału ustanowionego w fazie 1, strony połączenia występują w imieniu innych usług, takich jak np. IPsec.
Podtrzymanie sesji IKE (pakiety ) może odbywać się w warstwie IKE lub za pomocą protokołu DPD w warstwie IPseca.
Linki zewnętrzne
RFC 2407 The Internet IP Security Domain of Interpretation for ISAKMP, Internet Engineering Task Force (IETF) RFC 2408 Internet Security Association and Key Management Protocol (ISAKMP), Internet Engineering Task Force (IETF) RFC 2409 The Internet Key Exchange (IKE), Internet Engineering Task Force (IETF) RFC 5996: Internet Key Exchange (IKEv2) Protocol), Internet Engineering Task Force (IETF) Overview of IKE (from Cisco)
kategoria:Sieci komputerowe