Powiadomienia o stanie dostarczenia (DSN) DSN używana jest jednocześnie jako nazwa usługi, która może być opcjonalnie świadczona przez agentów przesyłania wiadomości (Message Transfer Agents/MTA) przy użyciu protokołu SMTP, oraz jako format wiadomości używany przy zwracaniu potwierdzeń do nadawcy wiadomości. W szczególności usługa DSN SMTP jest używana przy żądaniu potwierdzenia dostarczenia lub niepowodzenia dostarczenia wiadomości. Zwracanie potwierdzenia (w formacie DSN) po niepowodzeniu dostarczenia jest zachowaniem domyślnym, podczas gdy zwracanie DSN po pomyślnym dostarczeniu wymaga zdefiniowania żądania przez nadawcę wiadomości.
Trzeba jednak zdać sobie sprawę z tego, że wysłanie żądania nie implikuje otrzymanie odpowiedzi na to żądanie. Z różnych powodów możliwe jest dostarczenie wiadomości na serwer poczty elektronicznej i do nadawcy zwracany jest DSN wskazujący na to pomyślne dostarczenie, jednak wiadomość może nie być widziana przez odbiorcę ani nawet nie będzie mu udostępniana.
Rozszerzenie DSN SMTP, format wiadomości i powiązane kody stanu dostarczenia są określone w dokumentach od RFC 3461 do RFC 3464 i RFC 6522.