Интернет протокол версия 6 (IPv6) () е протокол от мрежово ниво за комуникационни мрежи, основани на предаването на пакети. Първоначално наричана IPng (), версия 6 на интернет протокола е създадена с цел да наследи IPv4, който е протоколът, насочващ почти целия интернет трафик.www.itwire.com

Мотивация IPv4 Първата публично използвана версия на интернет протокола – версия 4 (IPv4), предоставя адресно пространство от 232 или приблизително 4,3 милиарда адреса. В началото изчерпването на адресите в IPv4 не стояло като проблем на дневен ред, тъй като тази версия първоначално се предполагала, че е за вътрешен тест в рамките на DARPA и не била предназначена за обществено ползване.

Сравнение с IPv4 По-голямо адресно пространство Основното предимство на IPv6 пред IPv4 е, че IPv6 поддържа по-голямо адресно пространство. Дължината на един IPv6 адрес е 128 бита в сравнение с тази при IPv4, която е едва 32 бита.RFC 2460, Internet Protocol, Version 6 (IPv6) Specification, S. Deering, R. Hinden (December 1998) Адресното пространство следователно има 2128 или приблизително 3,4.1038 адреса. При класическо използване на IPv6 (използване само на unicast адресиране) това осигурява над милиард милиарда IP адреса за всеки един жител на Земята.

Други Plug and Play настройване със или без DHCP; По-добро оползотворяване на честотната лента чрез използване на unicast, multicast (вместо broadcast както при IPv4) и anycast; По-добра поддръжка на нивото на качество за всички приложения; Подобрена поддръжка за разширения и възможности за по-добро маршрутизиране; Нативна информационна структура за безопасност както за пакети с данни, така и за контролни пакети; Подобрена мобилност с бързо сменяне на каналите, маршрутна оптимизация и йерархична мобилност.

Формат на пакета IPv6 пакетът е разделен на две части: заглавна част – хедър () и payload (съставен от един или няколко допълнителни хедъра и данни). Хедърът заема първите 40 октета (320 бита) от IPv6 пакета. Той е съставен от: traffic class – 8 бита, задава се за определен пакет flow label – 20 бита, задава се за група от пакети версия на пакета – 4 бита със стойност 6 (0110) payload length – 16 бита следващ хедър () – 8 бита, указващ следващия хедър от payload-а брой рутирания () – 8 бита, задава се от източника на пакета и се намалява с 1 при всяко рутиране, като при стойност 0 пакетът се изоставя адрес на източника () – 128 бита адрес на получателя () – 128 бита

+Хедър на IPv6 пакета Октет 0 1 2 3 Бит 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 0 0ВерсияTraffic ClassFlow Label 4 32Payload LengthNext HeaderHop Limit 8 64Адрес на източника 12 96 16 128 20 160 24 192Адрес на получателя 28 224 32 256 36 288

Допълнителните хедъри са: hop-by-hop options хедър destination options хедър routing хедър fragment хедър authentication хедър encapsulating security payload хедър

Вижте също Internet Protocol

Основна спецификация RFC 2460: Internet Protocol, Version 6 (IPv6) Specification (obsoletes RFC 1883) RFC 2461/RFC 4311: Neighbor Discovery for IP Version 6 (IPv6) (4311 updates) RFC 2462: IPv6 Stateless Address Autoconfiguration RFC 4443: Internet Control Message Protocol (ICMPv6) for the IPv6 Specification (obsoletes RFC 2463) RFC 2464: Transmission of IPv6 Packets over Ethernet Networks RFC 4291: Internet Protocol Version 6 (IPv6) Addressing Architecture (obsoletes RFC 3513) RFC 3041: MAC address use replacement option RFC 3587: An IPv6 Aggregatable Global Unicast Address Format

Бележки

Категория:Протоколи от мрежовия слой