250px|mini|Pretvaranje lahko čitljivog formata IP-adrese u njenu binarnu vrijednost IP-adresa () jest jedinstveni broj koji se dodjeljuje svakom uređaju (npr. računaru ili pisaču) na računarskoj mreži koja za komuniciranje koristi internetski protokol.RFC 760, DOD Standard Internet Protocol (objavljeno u januaru 1980) Obavlja dvije osnovne funkcije: identificira mrežne interfejse i vrši adresiranje. Njena uloga opisana je na sljedeći način: "Ime umreženog računara govori nam šta tražimo. Adresa nam govori gdje se to nalazi. Ruta (mrežna putanja) govori nam kako do toga doći".RFC 791, Internet Protocol – DARPA Internet Program Protocol Specification (objavljeno u septembru 1981)
Autori Internetskog protokola definirali su IP-adresu koristeći 32-bitne brojeve, te se ovaj sistem, poznat kao IPv4 (), i dan-danas koristi. Međutim, s obzirom na vrlo brzo širenje interneta i predviđeni nedostatak dostupnih adresa, razvijena je nova verzija IP-a (IPv6), koja za adresu koristi 128 bita.RFC 1883, Internet Protocol, Version 6 (IPv6) Specification, S. Deering, R. Hinden (objavljeno u decembru 1995) Godine 1998. IPv6 je standardiziran pod oznakom RFC 2460 i njegova implementacija traje od sredine 2000-tih.RFC 2460, Internet Protocol, Version 6 (IPv6) Specification, S. Deering, R. Hinden, The Internet Society (objavljeno u decembru 1998)
IP-adrese se pišu i prikazuju u formatu koji je ljudima lahko čitljiv, npr. 172.16.254.1 (IPv4) i 2001:db8:0:1234:0:567:8:1 (IPv6).
Internet Assigned Numbers Authority (IANA) rukovodi dodjeljivanjem adresnog prostora IP-adresa širom svijeta i daje ovlaštenje petorici regionalnih internetskih registrara (RIR-a) da lokalnim internetskim registrima (dobavljačima internetskih usluga) dodjeljuju adresne blokove.
Također pogledajte
Internetski protokol Geolokacijski softver Hijerarhijski imenski prostor Lažiranje IP-adresa MAC adresa Ping Privatna mreža Regionalni internetski registar Računarska podmreža WHOIS
Reference
Vanjski linkovi IP na DMOZ-u "Razumijevanje IP-adresiranja: Sve što ste ikada željeli znati" . Arhivirano s originala 21. 8. 2010.
Kategorija:Mrežno adresiranje Kategorija:Internetski protokoli