Privátní síť je v informatice označení pro počítačovou síť, která využívá speciální privátní IP adresy podle standardů daných RFC 1918 a RFC 4193. Privátní adresy jsou běžně používány pro domácí, kancelářské a podnikové lokální sítě (LAN), kde veřejné adresy (tj. globálně směrovatelné v Internetu) nejsou žádoucí nebo nejsou dostupné. Privátní rozsahy IP adres byly definovány jako nástroj pro zpomalení vyčerpání IPv4 adres. Nyní jsou též součástí nastupující generace pro internetový protokol verze 6 (IPv6).
Privátní adresy jsou označovány jako soukromé, protože nejsou globálně delegované, což znamená, že nejsou přiděleny žádné konkrétní organizaci a jimi adresované IP pakety nemohou být přenášeny přes veřejný Internet. Kdokoliv může používat tyto adresy bez schválení od regionálního internetového registru (RIR). Pokud takováto privátní síť potřebuje připojení k Internetu, musí používat buď překlad síťových adres (NAT), nebo proxy server.
Privátní adresy jsou často nesprávně považovány za bezpečnostní opatření, je však nutné si uvědomit, že NAT a použití privátních adres samo o sobě žádnou bezpečnost nepřináší. Proč není NAT totéž co firewall: http://www.root.cz/clanky/proc-neni-nat-totez-co-firewall/
Privátní prostor IPv4 adres Internet Engineering Task Force (IETF) přikázala IANA zachování následujících rozsahů IPv4 adres pro soukromé sítě (publikováno v RFC 1918):
Označení RFC 1918 Rozsah IP adres Počet adres Největší CIDR blok (maska podsítě) Pro síťové rozhraní 24bitový blok 10.0.0.0 – 10.255.255.255 16 777 216 10.0.0.0/8 (255.0.0.0) 24 bitů 20bitový blok 172.16.0.0 – 172.31.255.255 1 048 576 172.16.0.0/12 (255.240.0.0) 20 bitů 16bitový blok 192.168.0.0 – 192.168.255.255 65 536 192.168.0.0/16 (255.255.0.0) 16 bitů
Privátní prostor IPv6 adres Koncept soukromých sítí a rezervací určitých adres je přenesen i do další generace IP, IPv6. IANA rezervovala adresový blok fc00::/7 (RFC 4193). Tyto adresy se nazývají unikátní lokální adresy (ULA). Jsou definované jako unicastové a obsahují 40bitové náhodné číslo ve směrovacím prefixu (předchází kolizím, když jsou dvě soukromé sítě propojené).
Link-local adresy Další typ soukromých sítí používá lokální linkový adresní rozsah popsaný v RFC 5735 a RFC 3927. Užitečnost těchto adres je v autokonfiguraci pomocí síťových zařízení, když není dostupné DHCP a manuální konfigurace není potřebná.
V IPv4 je k tomuto účelu vyhrazen blok 169.254.0.0/16. Pokud síťové rozhraní na síti Ethernet nemůže obdržet síťovou adresu pomocí DHCP, může mu být náhodně přidělena adresa od 169.254.1.0 do 169.254.254.255. Prvních 256 a posledních 256 adres z bloku 169.254/16 je vyhrazeno pro budoucí použití a nesmějí být použityRFC 3927 kapitola 2.1.
V IPv6 je vyhrazen blok fe80::/10RFC 4291 kapitola 2.4. Síťová část lokální adresy se skládá z prefixu o délce 10 bitů následovaného identifikátorem podsítě o délce 54 bitů, který je nulový. Zbylých 64 bitů reprezentuje identifikátor rozhraníRFC 4291 kapitola 2.5.6.
Misrouting Občas se stává, že pakety pocházející ze soukromého adresního prostoru projdou do Internetu. Soukromé sítě často nemají řádně nakonfigurované DNS pro vnitřní adresy, proto pokusy o určení jejich doménového jména způsobuje zbytečný síťový provoz.
Reference
Kategorie:Počítačové sítě