WebRTC () je definice API poskytujícího podporu pro telefonní hovory, video chat a peer-to-peer sdílení souborů aplikacím, které lze spustit ve webovém prohlížeči bez použití zásuvných modulůHow WebRTC Is Revolutionizing Telephony . Blogs.trilogy-lte.com (2014-02-21). Retrieved on 2014-04-11.. Pracovní verzi API vytvořilo World Wide Web Consortium (W3C).

Historie V květnu 2011 zveřejnila firma Google projekt s otevřenými zdrojovými kódy pro komunikaci v reálném čase pomocí webového prohlížeče známou jako WebRTC. Projekt vyvolal aktivitu směřující ke standardizaci relevantních protokolů v organizaci IETFCharter of Real-Time Communication in WEB-browsers (rtcweb) working group a API pro prohlížeč v organizaci W3C.

Pracovní verze dokumentu WebRTC konsorcia W3C popisuje prováděnou implementací v prohlížečích Chrome a Firefox. API je založeno na předběžné práci provedené v pracovní skupině WHATWG označovaná jako ConnectionPeer API a konceptu implementace předcházejím standardy vytvořeném v Ericsson Labs. Pracovní skupina WHATWG očekává (kdy??) další významný vývoj tohoto standardu založený na:

výsledcích prací probíhajících v rámci skupiny RTCWEB v IETF na definici sady komunikačních protokolů, které spolu s tímto dokumentem budou definovat komunikaci v reálném čase poskytovanou webovými prohlížeči otázkách soukromí, které vyvstávají při zpřístupňování lokálních funkcionalit a datových proudů technické diskusi uvnitř skupiny, především o implementaci datových kanálů zkušenostech získaných prvními experimenty zpětné vazbě od jiných skupin a jednotlivců

Struktura Hlavními komponenty WebRTC jsou:

getUserMedia umožňuje WWW prohlížeči používat kameru a mikrofon a zachycovat mediální proudy RTCPeerConnection navazuje audio a video spojení RTCDataChannels umožňuje prohlížeči sdílet data metodou peer-to-peer

WebRTC API obsahuje také statistické funkce:

getStats umožňuje WWW aplikacím získávat sadu statistik o WebRTC relacích; tato statistická data jsou popsána ve zvláštním W3C dokumentu

Pracovní verze dokumentu IETF "WebRTC kodek a požadavky na zpracování médií" () vydaná v březnu 2012 vyžaduje, aby implementace poskytovaly PCMA/PCMU (RFC 3551), telefonní události jako tóny tónové volby (RFC 4733) a kompresní formát Opus (RFC 6716), spolu s minimální funkcionalitou video kodeků. Dokument W3C detailně popisuje API webového prohlížeče pro Peerconnection, datové kanály a zachycování mediálních proudů.

Podpora WebRTC podporují následující prohlížeče:

Tradiční osobní počítače Google Chrome 23 Mozilla Firefox 22Firefox Notes - Desktop. Mozilla.org (2013-06-25). Retrieved on 2014-04-11. Opera 18Dev.Opera. My.opera.com. Retrieved on 2014-04-11. Microsoft Edge (Chromium based) Android Google Chrome 28 (implicitně povoleno od verze 29) Mozilla Firefox 24Firefox Notes - Desktop. Mozilla.org (2013-09-17). Retrieved on 2014-08-04. Opera Mobile 12 Google Chrome OS Firefox OS

V srpnu 2014 prohlížeče Internet Explorer a Safari neobsahovaly nativní podporu WebRTC. Podpora WebRTC pro tyto prohlížeče je v podobě zásuvných modulůhttp://www.prweb.com/releases/2014/05/prweb11844308.htm.

Odkazy Reference

Související články CU-RTC-WEB Jingle (protokol) Datagram Transport Layer Security (DTLS), Secure Real-time Transport Protocol (SRTP) – DTLS-SRTP je nezbytný protokol pro správu WebRTC klíčů

Externí odkazy

Official website Oficiální WWW server WebRTC W3C Web Real-Time Communication Working Group IETF Real-Time Communication in WEB-browsers (rtcweb) Working Group Google's open source WebRTC software project Contact centers could benefit from WebRTC WebRTC Book Getting Started With WebRTC WebRTC and Web Audio resources Real-time communication with WebRTC: Google I/O 2013 WebRTC Interest and History WebRTC News and Articles

Kategorie:World Wide Web