Zlib je svobodná a otevřená softwarová knihovna užívaná pro kompresi dat. Zlib byla napsána Jean-loup Gaillyem a Markem Adlerem a je abstrakcí kompresního algoritmu DEFLATE, který je použit např. v kompresním programu gzip. První veřejná verze 0.9 byla vydaná 1. května 1995 a původně byla určena pro použití s obrazovou knihovnou libpng. Knihovna je volný software s otevřeným zdrojovým kódem distribuovaný pod zlib licencí.
Software používající zlib Dnes je zlib prakticky standard až potud, že zlib a DEFLATE jsou ve standardních dokumentech často zaměňovány. Stovky aplikací pro Unixové operační systémy (jako je například Linux) tuto knihovnu pro kompresi využívají a je využívána i na dalších platformách, jako je například Microsoft Windows a PalmOS. Několik důležitých programů, které ji používají:
V Linuxovém jádře – komprese v síťových protokolech, komprese souborových systémů a dekomprese jádra při startu po jeho zavedení do paměti libpng – referenční implementace pro obrazový formát PNG, který specifikuje DEFLATE jako proudovou kompresi pro svou rastrovou grafiku (bitmapová data) Apache HTTP Server – využívá zlib k realizaci HTTP/1.1 OpenSSH klient a server – využívá zlib při volitelné kompresi bezpečnostního protokolu Secure Shell OpenSSL a GnuTLS knihovny – volitelná komprese TLS spojení FFmpeg multimediální knihovna – čtení a zápis DEFLATE části streamového formátu jako je Matroska rsync – volitelná komprese přenášených dat RPM Package Manager – RPM balíčky jsou komprimovány
Zlib je používána i v mnoha malých zařízeních, protože jeho kód je přenositelný, s liberální licencí a má relativně malé požadavky na paměť.
Související články ZIP (souborový formát)
Reference
Externí odkazy
domácí stránka zlib RFC 1950, RFC 1951, RFC 1952
Kategorie:Programové knihovny Kategorie:Kompresní programy Kategorie:Svobodný software v C