A Jetty egy tisztán Javában írt webszerver és servlet container. Míg a webszervereket általában az emberek dokumentumokkal való kiszolgálásával hozzák kapcsolatban, a Jettyt gyakran használják gép-gép közötti kommunikációra, különösen nagyobb szoftver keretrendszereken belül. A Jettyt szabad és nyílt forráskódú projektként fejlesztik, az Eclipse Foundation részeként. A webszervert olyan projektekben használják, mint például az Apache ActiveMQ, Alfresco, Apache Geronimo, Apache Maven, Apache Spark, Google App Engine, Eclipse, FUSE, iDempiere, Twitter's Streaming API és a Zimbra. Jetty olyan nyílt forráskódú projektek szervere, mint például a Lift, Eucalyptus, Red5, Hadoop és I2P. A Jetty támogatja a Java Servlet API-t (JSP támogatással) éppúgy, mint a HTTP/2 és WebSocket protokollokat.
Áttekintés
A projekt célja egy egyszerű, hatékony és beágyazható webszerver létrehozása. A Jetty kis méretéből eredően alkalmas web service-ek működtetésére beágyazott Java alkalmazásokban.
Független, nyílt forráskódú projektként fejlesztve 2009-ben a Jettyt átköltöztették az Eclipsehez. A Jetty képes webszolgáltatásokat nyújtani beágyazott Java alkalmazásokban. Mára része komponense az Eclipse IDEnek. Támogatja a következőket: AJP, JASPI, JMX, JNDI, OSGi, WebSocket és más Java-s technológiák.
Története
Eredetileg Sydneyben, Balmain-ben fejlesztette Greg Wilkins szoftverfejlesztő. Jetty eredetileg egy Mort Bay Szerver HTTP szerver komponense volt (Mort Bay Balmain egy körzete).
Jetty-t 1995-ben kezdték és MortBay szerverén volt elérhető az 1.x majd 2.x változat, egészen 2000-ig. 2000 és 2005 között, Jetty átkerült a sourceforge.net-re, ahol a 3.x, 4.x, majd 5.x verzió letölthető volt. 2005-ben az Jetty projektet átköltöztették a codehaus.org-ra. 2009-ben a főbb Jetty komponenseit átköltöztették az Eclipse.org-ra, és a Codehaus.org továbbra is nyújtott integrációt, kiegészítéseket, és Jetty csomagokat a 7.x és a 8.x verziókhoz (a 9.x-hez már nem). , About Jetty Located on Codehaus. , About Jetty Located on Eclispe.
Verzió Home Szükséges java verzió HTTP verzió Servlet verzió JSP Verzió Státusz 9.3.x Eclipse 1.8 HTTP/1.1, HTTP/2, WebSocket JSR356, SPDY 3.1 2.3 Stabil 2015-02-25 óta 9.2.x Eclipse 1.7 HTTP/1.1, WebSocket JSR356, SPDY 3.1 2.3 Stabil 2014-04-16 óta 9.1.x Eclipse 1.7 HTTP/1.1, WebSocket JSR356, SPDY 3.1 2.3 Stabil 2013-11-18 óta 9.0.x Eclipse 1.7 HTTP/1.1, WebSocket, SPDY 3.0 (tracking 3.1 drafts) 2.2 Stabil 2013-03-08 óta 8.x Eclipse, Codehaus 1.6 HTTP/1.1 RFC2616 3.0 2.1 Stabil 7.x Eclipse, Codehaus 1.5, J2ME HTTP/1.1 RFC2616 2.5 2.1 Stabil 6.x Codehaus 1.4-1.5 HTTP/1.1 RFC2616 2.5 2.0 Érett 5.x Sourceforge 1.2-1.5 HTTP/1.1 RFC2616 2.4 2.0 Elavult 4.x Sourceforge 1.2, J2ME HTTP/1.1 RFC2616 2.3 1.2 Nagyon régi 3.x Sourceforge 1.2 HTTP/1.1 RFC2068 2.2 1.1 Fosszilizált 2.x Mortbay 1.1 HTTP/1.0 RFC1945 2.1 1.0 Legendás 1.x Mortbay 1.0 HTTP/1.0 RFC1945 Mítikus
Kapcsolódó szócikkek Servlet containerek listája Java Servlet Java Platform, Enterprise Edition Apache Tomcat JavaServer Pages Webszolgáltatás
További információk Jetty honlapja Jetty Dokumentáció Jetty Fejlesztői Blog
Jegyzetek
Fordítás
Kategória:Alkalmazásszerverek Kategória:Eclipse szoftver