Questo elenco di tipi di record DNS consente di orientarsi facilmente fra i vari tipi di record usati dal DNS.
Record DNS normalmente in uso CodiceNumero IDRFC di riferimentoDescrizioneFunzione A11035 Record di indirizzo Restituisce un indirizzo IPv4 a 32 bit, normalmente usato per collegare un nome host al suo indirizzo IP. AAAA 283596 Record di indirizzo IPv6 Restituisce un indirizzo IPv6 a 128 bit, normalmente usato per collegare un nome host al suo indirizzo IPv6. AFSDB181183Record del database AFSPuntamento al server di database AFS. Questo record è usato dai client AFS per contattare un server AFS fuori dal proprio dominio. Un sottotipo di questo record era usato dall'obsoleto file system DCE/DFS.AXFR2521035 Trasferimento dell'intera zonaRichiesta di trasferimento dell'intera zona dal server principale ad un secondario. CERT 374398Record di certificatoTrasferisce un certificato di tipo PKIX, SPKI, PGP, ecc. CNAME 51035 Record di nome canonico Permette di collegare un nome DNS ad un altro. La risoluzione continuerà con il nuovo nome indicato dal record CNAME. Questa funzione è molto utile quando, ad esempio, sullo stesso server sono disponibili più servizi come FTP, HTTP, ecc. operanti su porte differenti. Ciascun servizio potrà avere il suo riferimento DNS (ad esempio ftp.example.com. e www.example.com.). È molto utile anche quando sullo stesso server ci sono più istanze web con differenti nomi ma usando lo stesso indirizzo. Questa funzione richiede, però, il supporto da parte del server di identità multiple con riconoscimento dell'intestazione HTTP.DHCID 494701Identificazione DHCPUsato in congiunzione con un record FQDN restituisce informazioni sul server DHCP.DLV327694431Record per la validazione DNSSECUsato per pubblicare un puntatore a un certificato DNSSEC fuori dalla catena di delegazione.DNAME392672Nome di delegazioneOpera in modo simile al record CNAME ma invece di far riferimento ad un singolo nome fa riferimento ad una porzione di albero DNS sotto un nuovo nome. Analogamente a CNAME la risoluzione continuerà con il nuovo nome.DNSKEY483755Record chiave DNSIl record chiave usato in DNSSEC.DS433658Delegazione del firmatarioUsato per identificare la chiave di firma DNSSEC per una zona delegata.HIP555205Host Identity ProtocolUn protocollo che consente di aumentare la sicurezza separando gli indirizzi IP degli host.IPSECKEY454025Chiave IPsecUsato per trasferire informazioni IPsec.IXFR2511995 Trasferimento di zona incrementaleTrasferisce la porzione di zona che è stata cambiata dal server DND principale ad un secondario.KEY254034Record chiaveUsato solo per TKEY (RFC 2930). Prima che fosse pubblicata l'RFC 3755 era anche usato per DNSSEC, attualmente DNSSEC usa DNSKEY.LOC291876 Record di localizzazione Associa una localizzazione geografica ad un nome DNS.MX151035 Server di posta Collega un nome di dominio ad una lista di server di posta autorevoli per quel dominio. I record indicano anche la preferenza di un server rispetto ad un altro.NAPTR353403 Naming Authority Pointer Un nuovo tipo di record DNS che supporta l'indirizzamento usando espressioni regolari. NS21035 Riferimento ai server DNS Delega una zona DNS ad essere gestita da un server DNS autorevole per quel nome di dominio.NSEC473755Record Next-SecureUsato da DNSSEC per stabilire se un nome non esiste.NSEC3505155Record NSEC versione 3Usato da DNSSEC.NSEC3PARAM515155Parametri NSEC3Parametri del record NSEC3.OPT412671OptionPseudo record DNS necessario per supportare EDNS.PTR121035 Record puntatore Puntatore ad un nome canonico usato per la risoluzione DNS inversa. Inserendo un record PTR per un nome canonico di dominio nella zona in-addr.arpa. (ip6.arpa. nel caso di IPv6) fa sì che si possa risalire al nome host dal suo indirizzo IP.RRSIG463755Firma DNSSECFirma per una serie di record DNSSEC sicuri.SIG242535FirmaRecord di firma usato in SIG(0) (RFC 2931). Prima che fosse pubblicata l'RFC 3755 era anche usato per DNSSEC, attualmente DNSSEC usa RRSIG.SOA61035 Record di start of authorityRestituisce informazioni autorevoli sulla zona DNS, incluso il server DNS principale, l'e-mail dell'amministratore, il numero seriale del dominio (utile per sapere se i dati della zona sono stati variati) e diversi timer che regolano la frequenza di trasferimento e la durata di validità dei record.SPF994408Record SPFSpecifica dati relativi al protocollo SPF. Deprecato come uso diretto (99) - Alternativa questi dati vengono inseriti in un record TXT.SRV332782Localizzatore di serviziUn servizio generalizzato di ricerca di servizi molto utile per nuovi protocolli per non dover aggiungere tipi di record specializzati come ad esempio il record MX.SSHFP444255Impronta della chiave pubblica SSHPubblica la chiave pubblica dell'host SSH sul DNS, in modo da aiutare la verifica dell'autenticità dell'host.TA32768NessunaCertificazione DNSSECParte della proposta DNSSEC senza una radice DNS firmata.TKEY2492930Chiave di transazioneSupporta un metodo per rendere sicuro il DNS. Implementa la sicurezza fra il server DNS che risolve la richiesta e il server autorevole di zona. DNSSEC, al contrario, rende sicuri i singoli record.TSIG2502845Firma di transazioneSupporta un insieme di meccanismi di sicurezza del DNS. Implementa la sicurezza fra il server DNS che risolve la richiesta e il server autorevole di zona. DNSSEC, al contrario, rende sicuri i singoli record.TXT161035Record di testoEra stato pensato per aggiungere commenti leggibili ad un record DNS. Dall'inizio degli anni novanta, invece, è usato per trasferire informazioni di sicurezza in accordo alla RFC 1464, opportunistic encryption, Sender Policy Framework e DomainKeys. Il sistema di DNS dinamico del server DHCP ISC usa campi di testo nelle zone dinamiche per identificare i record modificati dal server DHCP.
Altri tipi di record Il tipo di record 255 è riservato e significa "qualsiasi record". In nslookup scrivere type=all significa porre a 255 il campo tipo e richiedere quindi il trasferimento di qualsiasi tipo di record corrispondente alla risoluzione richiesta.
Ci sono poi altri tipi di record non normalmente usati e qui suddivisi per categoria di non uso.
Obsoleti: MD(3) da RFC 973 MF (4) da RFC 973 NXT(30) MAILB (253) MAILA (254) da RFC 973 Errori: NB(32) Il tipo 32 ora è usato per NIMLOC NBSTAT(33) (RFC 1002) Il tipo 33 ora è usato per SRV. Non ben definiti: AFSDB(18) X25(19) ISDN(20) RT(21) NSAP(22) NSAP-PTR(23) PX(26) EID(31) NIMLOC(32) ATMA(34) KX(36) A6(38) Sperimentali: MB(7) MG(8) MR(9) NULL(10) Resi inutili dalla nuova versione di DNSSEC introdotta dalla RFC 3755: NXT(30). Non normalmente in uso: WKS(11) dovrebbe fornire informazioni sui servizi di un host HINFO(13) fornisce informazioni sull'hardware e sulla versione di sistema operativo. Sconsigliato per motivo di sicurezza anche se molto usato in origine per cercare di comprendere problemi di incompatibilità. Attualmente fornendo queste informazioni ci si può esporre ad un attacco mirato. MINFO(14), RP(17) GPOS(27) SINK(40) APL(42) Riservati da IANA: UINFO(100) UID(101) GID(102) UNSPEC(103) Deprecati: SPF(99) usare il record TXT
Note
Bibliografia
Voci correlate Domain Name System Risoluzione DNS inversa
Collegamenti esterni
Categoria:Sistema dei nomi a dominio Categoria:Servizi di rete