DNSレコードタイプの一覧を以下に示す。Domain Name System(DNS)の内のリソースレコード(RR)の概要である。 また、擬似RR(pseudo-RRs)を含んでいる。

リソースレコード タイプ 値 (10進)RFC定義 説明 機能 A1 IPv4 IPアドレスレコード 32ビットのIPv4 IPアドレスを回答する。ホストのIPアドレスにホスト名 をマッピングするために使用する。また、でサブネットマスクを保存するためにDNSBLで使う。他 AAAA28 IPv6 IPアドレスレコード128ビットのIPv6 IPアドレスを回答する。ホストのIPアドレスにホスト名 をマッピングするために使用する。 AFSDB18AFS データベースレコードLocation of database servers of an AFS cell. This record is commonly used by AFS clients to contact AFS cells outside their local domain. A subtype of this record is used by the obsolete DCE/DFS file system. APL42アドレスのプレフィックスリストさまざまなアドレスファミリのアドレス範囲(例えばCIDR形式)のリストを指定する。実験的。 257認証局の認可DNS Certification Authority Authorization, constraining acceptable CAs for a host/domain CDNSKEY60子DNSKEYChild copy of DNSKEY record, for transfer to parent CDS59子 DSChild copy of DS record, for transfer to parent CERT 37証明書レコードStores PKIX, SPKI, PGP, etc. CNAMEレコード5RFC 1035 別名レコード(Canonical name record) 他の名称へのエイリアス(別名)で使用する。: the DNS lookup will continue by retrying the lookup with the new name.DHCID 49DHCP識別子Used in conjunction with the FQDN option to DHCPDLV32769DNSSEC Lookaside Validation レコードFor publishing DNSSEC trust anchors outside of the DNS delegation chain. Uses the same format as the DS record. describes a way of using these records.39Delegation 名Alias for a name and all its subnames, unlike CNAME, which is an alias for only the exact name. Like a CNAME record, the DNS lookup will continue by retrying the lookup with the new name.DNSKEY48DNS キー recordThe key record used in DNSSEC. Uses the same format as the KEY record.DS43Delegation signerThe record used to identify the DNSSEC signing key of a delegated zone55Host Identity プロトコルMethod of separating the end-point identifier and locator roles of IP addresses.HTTPS65DNS(SVCBおよびHTTPSリソースレコード)によるサービスバインディングおよびパラメータ仕様SVCB(「サービスバインディング」)とHTTPSリソースレコード(RR)は、サービスへのアクセスに関する完全な手順をクライアントに提供します。IPSECKEY45IPsec キーKey record that can be used with IPsecKEY25, §3 and , §1. "The KEY RR was defined in []..."キーレコードUsed only for SIG(0) () and TKEY ()., §2.4. "SIG(0) on the other hand, uses public key authentication, where the public keys are stored in DNS as KEY RRs and a private key is stored at the signer." eliminated their use for application keys and limited their use to DNSSEC., §1. "DNSSEC will be the only allowable sub-type for the KEY RR..." designates DNSKEY as the replacement within DNSSEC., §3. "DNSKEY will be the replacement for KEY, with the mnemonic indicating that these keys are not for application use, per [RFC3445]. RRSIG (Resource Record SIGnature) will replace SIG, and NSEC (Next SECure) will replace NXT. These new types completely replace the old types, except that SIG(0) [RFC2931] and TKEY [RFC2930] will continue to use SIG and KEY." designates IPSECKEY as the replacement for use with IPsec., Abstract. "This record replaces the functionality of the sub-type #4 of the KEY Resource Record, which has been obsoleted by ."KX36 鍵交換レコード Used with some cryptographic systems (not including DNSSEC) to identify a key management agent for the associated domain-name. Note that this has nothing to do with DNS Security. It is Informational status, rather than being on the IETF standards-track. It has always had limited deployment, but is still in use. 29 位置レコード Specifies a geographical location associated with a domain name MX15RFC 1035 and 電子メール交換レコード ドメインのメール転送エージェント(MTA)のリストとドメイン名をマッピングする。 35 Naming Authority Pointer Allows regular-expression-based rewriting of domain names which can then be used as URIs, further domain names to lookups, etc. NS2RFC 1035 ネームサーバーレコード DNSゾーン自身や下位ドメインのを指定するために使用するNSEC47Next-Secure recordPart of DNSSEC—used to prove a name does not exist. Uses the same format as the (obsolete) NXT record.NSEC350NSEC record version 3An extension to DNSSEC that allows proof of nonexistence for a name without permitting zonewalkingNSEC3PARAM51NSEC3 parametersParameter record for use with NSEC3 PTR12RFC 1035 ポインタレコード canonical nameへのポインタ。CNAMEとは異なり、DNS処理が停止し、名前のみ回答される。最も一般的な用途は、DNSの逆引きである。他の用途として、が含まれる。RRSIG46DNSSEC署名Signature for a DNSSEC-secured record set. Uses the same format as the SIG record.RP17担当者Information about the responsible person(s) for the domain. Usually an email address with the @ replaced by a .SIG24署名Signature record used in SIG(0) () and TKEY (). designated RRSIG as the replacement for SIG for use within DNSSEC. SOA6RFC 1035 and The minimum field of SOA record is redefined to be the TTL of NXDOMAIN reply in . Start of [a zone of] authority レコード DNSゾーンに関する特定のauthoritative情報。プライマリネームサーバ、ドメイン管理者の電子メール、ドメインのシリアル番号、ゾーンのリフレッシュに関連するいくつかのタイマーを含む。 33Service locatorGeneralized service location record, used for newer protocols instead of creating protocol-specific records such as MX. SSHFP44SSH公開鍵フィンガープリントResource record for publishing SSH public host key fingerprints in the DNS System, in order to aid in verifying the authenticity of the host. defines ECC SSH keys and SHA-256 hashes. See the IANA SSHFP RR parameters registry for details.SVCB64IETF ドラフトサービス割り当てRR that improves performance for clients that need to resolve many resources to access a domain. More info in this IETF Draft by DNSOP Working group and Akamai technologies.TA32768DNSSEC Trust AuthoritiesPart of a deployment proposal for DNSSEC without a signed DNS root. See the IANA database and Weiler Spec for details. Uses the same format as the DS record.249秘密鍵レコードA method of providing keying material to be used with that is encrypted under the public key in an accompanying KEY RR., §6. "... the keying material is sent within the key data field of a TKEY RR encrypted under the public key in an accompanying KEY RR []."52TLSA証明書アソシエーションA record for DNS-based Authentication of Named Entities (DANE). defines "The TLSA DNS resource record is used to associate a TLS server certificate or public key with the domain name where the record is found, thus forming a 'TLSA certificate association'".250Transaction SignatureCan be used to authenticate dynamic updates as coming from an approved client, or to authenticate responses as coming from an approved recursive name server, abstract similar to DNSSEC.16RFC 1035テキストレコード当初はDNSレコードで、人間が読めるテキスト形式のレコードだった。しかし、1990年代初頭以来、本レコードは、RFC1464で指定されたように、頻繁に機械可読データに利用されるようになった。日和見暗号化、Sender Policy Framework(SPF)、DKIM、DMARC、など。

他のタイプの擬似リソースレコード

コード番号Defining RFC説明機能*255RFC 1035全キャッシュレコードネームサーバーが保持している全てのタイプのすべてのレコードを回答する。ネームサーバーが情報を持っていない場合、要求は上位に転送される。回答されるレコードは、完全でない可能性がある。例えば、AレコードとMXレコードの両方があり、ネームサーバがAレコードのみをキャッシュしている場合、Aレコードのみ回答される。また、WindowsのnslookupやWiresharkなどで見られるように、"ANY"と呼ばれることもある。AXFR252RFC 1035 Authoritative ゾーン転送セカンダリネームサーバにマスターネームサーバからゾーンファイル全体を転送する。 IXFR251 増分ゾーン転送 前回のシリアル番号から指定されたゾーンの差分のゾーン転送を要求する。 OPT41オプションをサポートするために必要な「疑似DNSレコードのタイプ」である。

廃止されたレコードタイプ

Obsoleted by : MD(3), MF (4), MAILA (254) Records to publish mailing list subscriber lists in the DNS: MB(7), MG(8), MR(9), MINFO(14), MAILB (253). The intent, as specified by , was for MB to replace the SMTP VRFY command, MG to replace the SMTP EXPN command, and MR to replace the "551 User Not Local" SMTP error. Later, recommended that both the VRFY and EXPN commands be disabled, making the use of MB and MG unlikely to ever be adopted. Declared "not to be relied upon" by (with further information in ): WKS(11) section 2.2, 5.2.12, 6.1.3.6 Mistakes: NB(32), NBSTAT(33) (from ); the numbers are now assigned to NIMLOC and SRV. Obsoleted by : NULL(10) ( defined "completion queries" (opcode 2 and maybe 3) which used this record, later reassigned opcode 2 to be "status" and reserved opcode 3.) Defined as part of early IPv6 but downgraded to experimental by : A6(38), Later downgraded to historic in . Obsoleted by DNSSEC updates (): NXT(30). At the same time, the domain of applicability for KEY and SIG was also limited to not include DNSSEC use. Part of the first version of DNSSEC (). Not in current use by any notable application: HINFO(13), RP(17), X25(19), ISDN(20), RT(21), NSAP(22), NSAP-PTR(23), PX(26), EID(31), NIMLOC(32), ATMA(34), APL(42) Defined by the Kitchen Sink internet draft, but never made it to RFC status: SINK(40) A more limited early version of the LOC record: GPOS(27) IANA reserved, no RFC documented them and support was removed from BIND in the early 90s: UINFO(100), UID(101), GID(102), UNSPEC(103) SPF(99) (from ) was specified as part of the Sender Policy Framework protocol as an alternative to storing SPF data in TXT records, using the same format. It was later found that the majority of SPF deployments lack proper support for this record type, and support for it was discontinued in .

RP(17) may be used for certain human-readable information regarding a different contact point for a specific host, subnet, or other domain level label separate than that used in the SOA record.

参考

出典・脚注

関連項目 DNSサーバー