Електронска пошта, попозната како е-пошта или e-mail, е метод за размена на дигитални пораки од авторот до еден или повеќе примачи. Модерниот е-мејл работи низ интернет или други компјутерски мрежи. Некои рани системи за електронска пошта барале и авторот и примателот да се онлајн во исто време, слично како со инстант пораки. Системи за електронска пошта денес се врз основа на зачувај и препрати моделот. опслужувачи за е-пошта прифаќаат, препраќаат, доставуваат и чуваат пораки. Ниту за корисниците, ниту за нивните компјутери е потребно да бидат онлајн истовремено, тие треба поврзат само за кратко, обично на опслужувач за електронска пошта, колку што е потребно за да праќаат и примаат пораки.
Е-пошта порака се состои од три компоненти,пликот на пораката, насловот на пораката и тело на пораката. Насловот на пораката содржи контрола на информации, вклучувајќи ги, најмалку, авторот на електронска пошта и една или повеќе адреси на примачот. Обично исто така се додаваат описни информации како што е насловот во полето за предмет и печат за датум / време на праќање на пораката.
Првично е само текстуален (7-битни ASCII и други) комуникациски медиум, а сега е-мејлот е проширен и може да се прикачуваат додатоци со мулти-медиална содржина, процес стандардизиран во RFC 2045 преку 2049. Колективно, овие RFC се наречени мултинаменски е-поштенски домени (MIME).
Електронска пошта претходи на почетокот на интернет, и е всушност клучна алатка во создавањето на истиот,See for early history of email, from origins through 1991. но историјата на модерни, глобални интернет-мејл услуги достигнува до почетокот на ARPANET. Стандарди за кодирање на e-mail пораки беа предложени уште во 1973 (RFC 561). Претворање од ARPANET на интернет во раните 1980-ти го произведе јадрото на тековните услуги. Е-пошта испратен во раните 1970-ти изгледа доста сличен на основнаата текст порака испратена на интернет денес.
Електронски писма засновани на мрежа првично беа разменувани на ARPANET во екстензии на протокол за пренос на податотеки (FTP), но сега тоа е извршено од страна на Протокол за пренос на едноставна пошта (SMTP), првпат објавен на интернет стандард 10 (RFC 821) во 1982 година. Во процесот на транспорт на е-мејл пораки помеѓу системите, SMTP комуницира со испорака на параметри користејќи го пликот на пораката одвоено од пораката и (заглавјето и телото) за себе.
Правопис Електронската пошта, има неколку опции за англиски правопис кои повремено се покажуваат како причина за несогласување.
Е пошта е во форма побарана од страна на IETF Барања за коментар и работни групи и повеќе е водено од аспект на стил.AP Stylebook editors share big changes from the American Copy Editors Society Овој правопис исто така се појавува во повеќето речници.Reference.comRandom House Unabridged Dictionary, 2006The American Heritage Dictionary of the English Language, Fourth EditionPrinceton University WordNet 3.0The American Heritage Science Dictionary, 2002 E-mail е форма претходно препорачана од некои истакнати новинарски и технички водичи за стил. Според корпусот на современиот американско англиски јазик на податоци, оваа форма се појавува најчесто изменето, објави американско-англиското пишување. Пошта е форма која се користи во оригиналниот RFC. Услугата е наведена како пошта и едно парче на електронска пошта се нарекува порака.RFC 821 (rfc821) - Simple Mail Transfer ProtocolRFC 1939 (rfc1939) - Post Office Protocol - Version 3RFC 3501 (rfc3501) - Internet Message Access Protocol - version 4rev1
Потекло Пренасочувања Испраќање на текстуални пораки по електронски пат може да се каже дека датира од Morse code телеграф од средината на 1800-тите; На светскиот саем 1939 во Њујорк, каде IBM испрати писмо со честитки од Сан Франциско до Њујорк на IBM радио-тип, нарекувајќи со набрзо замена за mail сервисот во светот на утрешнината."The Watsons: IBM's Troubled Legacy" Телепринтери се користени во Германија за време на Втората светска војнаSee File:Gestapo anti-gay telex.jpg и употребата се шири до крајот на 1960-тите години кога била претставена Телекс мрежа. Покрај тоа, имало слични, но некомпатибилен американски TWX, кој остана во употреба до крајот на 1980-тите."Telex and TWX History" , Donald E. Kimberlin, 1986
Хост-засновани системи за пошта Со воведувањето на Систем за компатибилно споделување (CTSS) во 1961 година од страна на МИТ"CTSS, Compatible Time-Sharing System" (September 4, 2006), University of South Alabama, http://www.cis.usouthal.edu/faculty/daigle/project1/ctss.htm USA-CTSS]. за првпат повеќе корисници беа во можност да влезат во централниот системan IBM 7094 од далечински dial-up терминали, за чување и споделување додадени фајлови на централниот диск.. Tom Van Vleck, "The IBM 7094 and CTSS" (September 10, 2004), Multicians.org (Multics), web: Multicians-7094.
Неслужбени начини на користење на ова е да поминат пораки и да се прошири за да се создаде првиот вистински е-пошта: Систем за компатибилно споделување (CTSS) од МИТ, во 1965 година
Други рани системи за споделување имаа свои е поштенски апликации: 1972 - Unix пошта програмата 1972 - APL поштенското сандаче од раса ЛариAPL Quotations and Anecdotes, including Leslie Goldsmith's story of the Mailbox 1981 - ресор од страна на IBM 1982 - All-In-1] Gordon Bell's timeline of Digital Equipment Corporation од Digital Equipment Corporation
Иако имаат сличен концепт, сите овие оригинални системи за електронска пошта се со многу различни одлики и излегоа некомпатибилни системи. Тие дозволија комуникација само помеѓу корисниците најавени во ист хост или "супер" - иако ова може да биде стотици или дури и илјадници корисници во рамките на една организација.
Е-поштенски мрежи Наскоро беа развиени системи за поврзување на програми за компатибилна пошта помеѓу различни организации преку дајл-ап модеми или изнајмени линии, создавање на локални и глобални мрежи.
Во 1971 година, првиот ARPANET e-mail бил испратен, и преку 561 RFC, RFC 680, RFC 724 и конечно 1977 е RFC 733, стана стандардизиран систем за работа.
Други одделни мрежи беа исто така создавани и тоа: Unix пошта е вмрежена од 1978 UUCP, IBM супер-мејл е поврзана со BITNET во 1981 година IBM кој работи во ДОС во 1984 година може да се поврзе со fidonet за е-мејл и објавување на заедничка огласна табла
LAN системи за електронска пошта Во раните 1980-ти, мрежни лични сметачи на LAN станаа многу значајни. опслужувач-засновани системи слични на претходните супер системи беа развиени. Повторно овие системи првично дозволено комуникација само помеѓу корисниците најавени во истата опслужувачка инфраструктура. Примерите вклучуваат: cc:Mail Lantastic WordPerfect Office Microsoft Mail Banyan VINES Lotus Notes
Конечно овие системи исто така, може да се поврзат меѓу различни организации, додека тие, користат ист е-мејл систем и комерцијален протокол.with various vendors supplying gateway software to link these incompatible systems
Обиди за интероперабилност Почетокот на интероперабилност меѓу независни системи вклучува:
ARPANET, претходник на интернет денес, дефинирани првите протоколи за различни компјутери за размена на e-mail UUCP имплементација на не-Unix системи беа користени како отворено „лепило“ меѓу различни поштенски системи, првенствено преку дајл-ап телефони CSNet се користи dial-up пристап до телефонски линк дополнителни на сајтови на ARPANET и потоа Интернет
Подоцнежните напори за интероперабилност на стандардизација вклучуваат: Novell накратко се залагале за отворено MHS протокол, но го напуштен по купување на не-MHS WordPerfect Office (преименуван во GroupWise) На обоени протоколи на книга на Обединетото Кралство за академските мрежи до 1992 година X.400 во 1980-тите и раните 1990-ти бил промовиран од страна на големите производители и го употребувала Владата под GOSIP, но е напуштен од сите во корист на интернет SMTP до средината на 1990-тите години.
Од SNDMSG до MSG Во раните 1970-ти, Реј Томлинсон ја обновi постоечкаta алатка наречена SNDMSG, така што тоа би можело да се направи копија од пораки (како фајлови) преку мрежата. Лоренс Робертс, менаџерот на проектот за развој на ARPANET, ја зеде идејата за READMAIL, кога биле фрлени "последните" пораки кон терминалот на корисникот, и напишал програмата за TENEX во Teco макроа наречени RD кои му овозможија пристап до поединечни пораки.Email History Barry Wessler then updated RD and called it NRD."The Technical Development of Internet Email" Craig Partridge, April–June 2008, p.5
Марти Yonke комбинирано ги пренапиша NRD за да го вклучи читањето, пристап до SNDMSG за испраќање, и систем за помош, и да повика на нови WRD која подоцна биле познати како BANANARD. Џон Vittal тогаш ја има обновено оваа верзија за да вклучи 3 важни команди:Поместување (во комбинација спаси / избриши команда), Одговор (утврдува кој одговор треба да биде испратен) напред (Испрати е-пошта на лице кое не е веќе примател). Системот е наречен MSG. Со вклучување на овие одлики, MSG се смета за првата интегрирна модерна e-mail програма, од кои многу други апликации се спуштаа.
Подемот на ARPANET пошта ARPAnet компјутерска мрежа направи голем придонес во развојот на е-мејл. Постои еден извештај кој покажува експерименти меѓу систем-мејл трансфери кој почна кратко време по неговото формирање во 1969 година. Реј Томлинсон обично е заслужен што е испратен прв мејл преку мрежа, започнување на користење на "@" знак за поделба на имињата на корисникот и машината на корисникот во 1971 година, кога испрати порака од еден Digital Equipment Corporation декември-10 компјутер на друг Dec-10. Двете машини се сместени еден до друг.Wave New World,Time Magazine, October 19, 2009, p.48 Работата на Томлинсон била брзо усвоена низ ARPANET, со што значително се зголеми популарноста на е-мејл. За многу години, е-мејл е Killer App на ARPANET, а потоа на интернет.
Повеќето други мрежи имаа свои e-mail протоколи и формати на адреси, како влијание на ARPANET, а подоцна и на интернет се зголеми, централна сајтови често беа домаќини на е-мејл портали кои ја положиле поштата меѓу интернет и другите мрежи. Интернет e-mail адресирање сè уште е комплицирана од потребата да се справи поштата наменета за овие постари мрежи. Некои добро познати примери од нив биле UUCP (најчесто Unix компјутери), BITNET (најчесто IBM и VAX главно на универзитетите), fidonet (лични сметачи), DECnet (различни мрежи) и CSNET претходник на NSFNet.
Еден пример на интернет e-mail адреса која изнесе mail на корисникот во домаќин UUCP:
hubhost!middlehost!edgehost!user@uucpgateway.somedomain.example.com
Ова е потребно бидејќи во раните години UUCP компјутери не се одржуваа (и не можеле да се консултираает централните опслужувачи за) информации за локацијата на сите домаќини кои се разменија со е-пошта, туку само се знаело како да комуницира со неколку соседни мрежи, е-мејл пораки (и други податоци како што се Usenet Вести) беа донесени заедно во синџирот меѓу домаќините кои експлицитно се согласија да разменуваат податоци едни со други. (Крајот на UUCP проект за мапирање обезбеди форма на мрежа за насочување врз основа на податоци за е-мејл.)
Заглавје на порака Секоја порака има точно еден наслов, кои се поделени во области. Секоја област има име и вредност. RFC 5322 ја одредува точната синтакса.
Неформално, секоја линија на текст во насловот кој започнува со печатење на карактери кога започнува посебна област. Во полето Име започнува со првиот лик на линијата и завршува пред сепаратор карактерот ":". Сепаратор потоа се следи од областа вредност ("телото" на поле). Вредноста се продолжува кон следните линии ако тие линии имаат простор или јазиче како нивниот прв карактер. Областа имиња и вредности се ограничени на 7-битни ASCII карактери. Не-ASCII вредности можат да бидат претставени со MIME кодирани зборови.
Заглавја Насловот на пораката мора да ги содржи најмалку следните полиња:RFC 5322, 3.6. Field Definitions