Подмрежа или subnetwork е логичко видлива поделба на IP-мрежа. Поделбата на мрежа на две или повеќе мрежи е наречено одделување на подмрежи(сабнетирање).
Сите компјутери кои припаѓаат на подмрежа се адресирани со заедничка, идентична, најважна бит-група во нивните IP-адреси. Ова резултира во логичката поделба на IP-адресата на два дела: мрежен или насочувачка претставка и делот за уред, односно идентификатор за домаќин. Делот за уред е идентификатор за посебен домаќин или мрежен интерфејс.
Насочувачката претставка е изразена во CIDR-нотација. Се запишува како првата мрежна адреса, проследена со коса црта нанапред (/), а завршува со бит-должината на претставката. На пример, 192.168.1.0/24 е претставка на IPv4, која има 24 бита за алокација на мрежна претставка и 8 бита резервирани за домаќин. Спецификацијата за IPv6 адресата(2001:db8::/32) е огромен адресен блок со 296 адреси, кој има 32-битна насочувачка претставка. Kaj IPv4, мрежата исто така се одликува со подмрежна маска која е битмапата која применета со логичко И-операција на било која IP-адреса во мрежата ја дава насочувачката претставка. Мрежните маски се изразуваат со децимална нотација одделена со точки (x.x.x.x, каде x=[0,...,255]) исто како и адресите. На пример, 255.255.255.0 е мрежната маска за 192.168.1.0/24.
Подмрежите разменуваат (насочуваат) сообраќај меѓу себе преку посебни гранични компјутери (насочувачи-насочувачи) кога насочувачките претставки на адресата на изворот и адресата на одредиштето се разликуваат. Насочувачот претставува логичка или физичка граница помеѓу подмрежите.
Придобивките од одделувањето на подмрежи на веќе постоечка мрежа се разликуваат за секое распределување поединечно. Во архитектурата за адресна алокација на Интернетот со користење на бескласно интер-доменско насочување(Classless Inter-Domain Routing (CIDR)) и во поголемите организации, доста неопходно е ефикасно да се алоцира адресниот простор. Одделувањето на подмрежи се прави за да се зголеми ефикасноста на насочувањето или да има предности во администрацијата на мрежата кога подмрежите се под административна контрола на различни ентитети во една поголема организација. Подмрежите можат да бидат подредени логички - во хиерархиска структура, со поделување на мрежниот адресен простор на една организација во насочувачка структура во вид на дрво.
Мрежно адресирање и насочување Сите компјутери кои се дел од една мрежа како што е Интернетот имаат барем една логичка адреса. Обично оваа адреса е уникатна за секој уред и може да се конфигурира автоматски преку Dynamic Host Configuration Protocol (DHCP) од страна на мрежен опслужувач, рачно од страна на администратор, или автоматски со користење на адресна автоконфигурација без состојби(stateless address autoconfiguration).
Адресата ја исполнува функцијата да го идентифицира домаќинот и да го лоцира каде се наоѓа на мрежата. Најчесто користената архитектура за мрежно адресирање е Интернет Протоколот верзија 4 (IPv4), но неговиот наследник, IPv6, сè повеќе се става во употреба, од 2006 година па наваму. Една IPv4 адреса се состои од 32 бита, која за читливост се запишува како 4 октети одделени со точка или наречена децимална нотација одделена со точки (dot-decimal notation. Една IPv6 address е составена од 128 бита запишани во хексадецимална нотација, групирани по 16 бита одделени со две точки.
За потребите на управување со мрежите, една IP-адреса е поделена на два логички дела, мрежната претставка и идентификаторот на домаќинот (дел за домаќинот). Сите домаќини на една подмрежа го имаат истата мрежна претставка. Оваа мрежна претставка ги зафаќа битовите со најголема важност од адресата. Бројот на битови алоциран внатре во една мрежа за внатрешната насочувачка претставка може да варира од подмрежа до подмрежа, во зависност од мрежната архитектура. Додека во IPv6 претставката мора да се состои од последователни битови со вредност 1, во IPv4 ова не е условено. Сепак нема некоја предност кон користењето на непоследовалтени битови со вредност еден. Делот за домаќинот е уникатна локална идентификација и е или број на домаќинот на локалната мрежа или идентификатор на мрежниот интерфејс.
Оваа логичка структура на адресирањето дозволува селективно насочување на IP пакетите низ повеќе мрежи преку користење на специјални гранични компјутери (gateway) наречени насочувачи (насочувачи), до дестинацискиот хост ако мрежните претставки на домаќинот испраќач и дестинацискиот домаќин се разликуваат. Логичката структура на адресирањето дозволува и директно испраќање до дестинацискиот домаќин кој е на иста локална мрежа со испраќачот. Насочувачите претставуваат логички и физички граници меѓу подмрежите и го менаџираат сообраќајот помеѓу нив. Секоја подмрежа е опслужувана од претпоставен насочувач (designated default router), но може да е составена интерно од повеќе физички Етернет сегменти поврзани со мрежни преклопници или мрежни мостови.
Насочувачката претставка на една адреса се пишува во форма идентична на самата адреса. Ова се нарекува уште и мрежна маска на адресата. На пример, специфицирањето на 18те битови со најголемо значење на една IPv4 адреса кое е 11111111.11111111.11000000.00000000, се запишува како 255.255.192.0. Ако оваа маска означува и подмрежа во поголема мрежа, уште се нарекува и подмрежна маска. Ова форма на означување на мрежната маска се користи само кај IPv4 адреси.
Модерната стандардна форма за специфицирање на мрежна претставка е CIDR нотација и се користи во IPv4 и IPv6. Со оваа форма се брои бројот на битови во претставката и се додава на адресата после коса црта (/) како сепаратор: 192.168.0.0, со мрежна маска 255.255.255.0 се запишува како 192.168.0.0/24 Во IPv6, 2001:db8::/32 ја означува адресата 2001:db8:: и нејзината мрежна претставка се состои од првите 32 бита со најголемо значење.
Оваа нотација беше претставена со Бескласното интер-доменско насочување (CIDR) во RFC 4632. Во IPv6 ова едниствената прифатлива форма за означување на мрежните и насочувачките претставки. Во класните мрежи во IPv4, пред појавувањето на CIDR, мрежната претставка се одредува од класата на IP-адресата (A, B, C...). Во IPv4, за да се одреди дали една IP-адреса се наоѓа на истата подмрежа доволно е да се има адресата и подмрежата, бидејќи адресата не може да биде одделена од мрежната претставка.RFC 1122, Requirements for Internet Hosts -- Communication Layers, Section 3.3.1, R. Braden, IETF (October 1989) За IPv6, потребно е да се користи Протоколот за откривање на соседи(Neighbor Discovery Protocol (NDP)).RFC 4861, Neighbor Discovery for IP version 6 (IPv6), T. Narten et al. (September 2007)RFC 5942, IPv6 Subnet Model: The Relationship between Links and Subnet Prefixes, H. Singh, W. Beebee, E. Nordmark (July 2010) Доделувањето на IPv6 на интерфејс не носи никакви барања за поклопување на мрежната претставка на со таа на адресите на другите интерфејси на истиот линк. Создавањето на подмрежи може да ги подобри перформансите во една организацика мрежа по цена на комплексноста за насочување, бидејќи секоја локална подмрежа мора да биде претставена како одделен запис во насочувачката табела на секој поврзан насочувач. Сепак, со внимателен дизајн на мрежата, рутите кон колекции од подалечни подмрежи може да се агрегираат. Интернетот и мрежите во фирмите можеа без проблеми да преминат на CIDR со појавата на фунционалноста за Подмрежни маски со променлива должина(Variable-length subnet masking (VLSM)) во комерцијалните насочувачи. IPv4 сабнетирање Процесот на сабнетирање вклучува одвојување на мрежата и подмрежниот дел на една адреса од идентификаторот за домаќин. Ова се извршува со битово И(bitwise AND)-операција помеѓу IP-адресата и (под)мрежната маска. Резултат е мрежната адреса (или претставка), а остаток е идентификаторот на домаќин. Утврдување на мрежна претставка Една IPv4 мрежна маска, која е составена од 32 бита е секвенца од кецови проследена со блок од нули. Крајниот блок од нули претставува идентификатор за домаќин. Наредниот пример го покажува утврдувањето на мрежната претставка и идентификаторот за домаќин од адресата 192.168.5.130 и нејзината /24 мрежна маска (255.255.255.0). Постапката е прикажана во табела користејќи бинарни(binary) форми за адресите. Бинарна форма Децимална нотација одделена со точка IP-адреса 11000000.10101000.00000101.10000010 192.168.5.130 Подмрежна маска 11111111.11111111.11111111.00000000 255.255.255.0 Мрежна претставка 11000000.10101000.00000101.00000000 192.168.5.0 Дел за домаќин 00000000.00000000.00000000.10000010 0.0.0.130 Математичката операција за пресметување на мрежна претставка е битово И(bitwise AND) на IP-адресата и подмрежната маска. Резултатот го дава мрежниот претставка 192.168.5.0 и бројот за домаќин 130.
Создавање на подмрежи (Сабнетирање) Сабнетирањето е процес во кој со назначување на некој од битовите со висока важност од делот за домаќин и нивно поврзување со мрежната маска се формира подмрежна маска. Овој процес ја одделува мрежата на помали мрежи наречени подмрежи. Во следната табела е прикажан пример со преместување на 2 бита од делот за домаќин на подмрежната маска за да се формираат четири помали подмрежи, со големина ¼ од претходната.
Бинарна форма Децимална нотација одделена со точки IP-адреса 11000000.10101000.00000101.10000010 192.168.5.130 Подмрежна маска 11111111.11111111.11111111.11000000 255.255.255.192 Мрежна претставка 11000000.10101000.00000101.10000000 192.168.5.128 Дел за домаќин 00000000.00000000.00000000.00000010 0.0.0.2 Специјални адреси и подмрежи Интернет протоколот верзија 4(IPv4) користи специјално дизајнирани адресни формати за да го олесни препознавањето на функционирањето на специјалните адреси. Почетната и крајната подмрежа добиени со сабнетирање имаат специјална ознака и импликации за специјална употреба. Покрај тоа, IPv4 ја користи адресата на домаќин која се состои само од единици, т.е. крајната адреса во рамките на една мрежа, за емитување на пренос до сите домаќини во врската.
Подмрежа составена само од нули и подмрежа составена само од единици Сите битови на почетната подмрежа добиена со сабнетирање се нули (0). Заради тоа е наречена „подмрежа составена само од нули“. Сите битови на крајната подмрежа добиена со сабнетирање се единици (1). Затоа се нарекува и „подмрежа составена само од единици“'.
На почетокот, IETF го обесхрабрува користењето на овие две подмрежи поради можни забуни при користење на мрежа и подмрежа со иста адреса.RFC 950, Практиката на избегнување на подмрежата составена само од нули и подмрежата составена само од единици бил прогласен за неважечки во 1995 од RFC 1878, некогаш информативен, но сега историски документ.RFC 1878, (Informational RFC, demoted to category Historic)
Создавање на подмрежи во IPv6 Дизајнот на адресниот порстор на IPv6 значително се разликува од тој на IPv4. Првичната причина за создавањето на подмрежи во IPv4 е за да се подобри ефикасноста во користењето на релативно малиот адресен простор, особено на големите претпријатијата. Во IPv6 не постојат такви ограничувања, бидејќи големиот адресен простор кој е на располагање и на крајните корисници не е ограничувачки фактор.
Подмрежа која е во согласност со RFC 4291 секогаш користи IPv6 адреси со 64 бита дел за домаќин.RFC 4291, Затоа таа подмрежа има /64 насочувачка претставка (128−64 = 64те битови со најголема важност). Иако е технички можно да се користат помали подмрежи,RFC
4862, тие се непрактични за локални мрежи засновани на Етернет технологијата, бидејќи 64 бита се потребни за адресна автоконфигурација без состојби.RFC
2464, Internet Engineering Task Force предлага да се користат /127 подмрежи за точка-до-точка (point-to-point) врски кои содржат само два домаќина.RFC
6164, RFC 6547,
IPv6 нема специјални адресни формати за бродкаст сообраќај или броеви на мрежи,RFC 4291, со тоа сите адреси во една подмрежа се валидни адреси на домаќини. Адресата со сите нули е резервирана за насочувачот на таа подмрежа (Subnet-Router anycast address).RFC 4291,