Stream Control Transmission Protocol (SCTP) er en avansert protokoll for transportlaget i OSI-modellen, som kanskje vil avløse TCP en dag.

Standardiseringsdokumenter RFCs RFC 6525 Stream Control Transmission Protocol (SCTP) Stream Reconfiguration RFC 6458 Sockets API Extensions for the Stream Control Transmission Protocol (SCTP) RFC 6096 Stream Control Transmission Protocol (SCTP) Chunk Flags Registration (updates RFC 4960) RFC 5062 Security Attacks Found Against the Stream Control Transmission Protocol (SCTP) and Current Countermeasures RFC 5061 Stream Control Transmission Protocol (SCTP) Dynamic Address Reconfiguration RFC 5043 Stream Control Transmission Protocol (SCTP) Direct Data Placement (DDP) Adaptation RFC 4960 Stream Control Transmission Protocol RFC 4895 Authenticated Chunks for the Stream Control Transmission Protocol (SCTP) RFC 4820 Padding Chunk and Parameter for the Stream Control Transmission Protocol (SCTP) RFC 4460 Stream Control Transmission Protocol (SCTP) Specification Errata and Issues RFC 3873 Stream Control Transmission Protocol (SCTP) Management Information Base (MIB) RFC 3758 Stream Control Transmission Protocol (SCTP) Partial Reliability Extension RFC 3554 On the Use of Stream Control Transmission Protocol (SCTP) with IPsec RFC 3436 Transport Layer Security over Stream Control Transmission Protocol RFC 3309 Stream Control Transmission Protocol (SCTP) Checksum Change (obsoleted by RFC 4960) RFC 3286 An Introduction to the Stream Control Transmission Protocol RFC 3257 Stream Control Transmission Protocol Applicability Statement RFC 2960 Stream Control Transmission Protocol (updated by RFC 3309 and obsoleted by RFC 4960)

Working Group drafts SACK-IMMEDIATELY Extension for the Stream Control Transmission Protocol Stream Control Transmission Protocol (SCTP) Network Address Translation Support Stream Control Transmission Protocol (SCTP) Network Address Translation DTLS Encapsulation of SCTP Packets for RTCWEB UDP Encapsulation of SCTP Packets for End-Host to End-Host Communication

Andre drafts Load Sharing for the Stream Control Transmission Protocol (SCTP) Additional Policies for the Partial Delivery Extension of the Stream SCTP Socket API Extensions for Concurrent Multipath Transfer Secure SCTP Sender Queue Info Option for the SCTP Socket API Pluggable Stream Scheduling for the Stream Control Transmission Protocol Quick Failover Algorithm in SCTP Non-Renegable Selective Acknowledgements (NR-SACKs) for SCTP Mobile SCTP Load Sharing in Stream Control Transmission Protocol

Eksterne lenker SCTP for Beginners (PDF; 277 kB) Michael Tüxen's SCTP Page Lode Coene's SCTP Page Thomas Dreibholz's SCTP Project Page OpenSS7 Better networking with SCTP Concluded Workgroup Signaling Transport (sigtran) IETF Transport Area Working Group (TSVWG)

Kategori:Datanett Kategori:Internett-protokoller