В компьютерных сетях протокол организации туннеля (Tunnel Setup Protocol, TSP) — это экспериментальный протокол управления сетевым соединением, используемый для согласования параметров настройки IP-туннеля между узлом туннельного клиента и сервера туннельного брокера, так называемыми конечными точками туннеля (RFC 5572). Основное применение TSP — это механизм перехода на протокол IPv6.
Согласуемые данные Протокол TSP определяет следующие действия:
Аутентификацию пользователя с использованием протокола Simple Authentication and Security Layer (SASL) (RFC 4422). Инкапсуляцию туннеля для различных сценариев туннелирования: Туннель IPv6 через IPv4 (RFC 4213) Туннель IPv4 через IPv6 (RFC 2473) Туннель IPv6 через UDP/IPv4 для встроенного обхода транслятора сетевых адресов (NAT) Задание IP-адресов для обеих конечных точек туннеля Регистрацию конечных точек в DNS и RDNS Использование механизма Keep-alive при необходимости Назначение префикса адресов IPv6 для маршрутизатора Указание протокола маршрутизации
Сессия протокола Сессия TSP инициируется TSP-клиентом с целью установления сквозного туннеля с TSP-сервером (туннельным брокером). Сессия состоит из базового обмена XML-закодированными данными с использованием протокола TCP или UDP. После согласования параметров настройки туннеля сессия завершается, и клиент приступает к настройке локальной конечной точки туннеля.
Ссылки IPv6 TSP Server Implementation IPv6 TSP Client implementation
Категория:IPv6 Категория:Сетевые протоколы Категория:Протоколы туннелирования