«ENUM» перенаправляется сюда. Для перечисляемых типов в языках программирования, см. перечисляемый тип.

ENUM (или Enum, от E.164 NUmber Mapping) — набор протоколов для объединения системы нумерации телефонов E.164 с системой адресации интернет, а DNS при использовании косвенного метода поиска получает записи NAPTR. Записи хранятся в базе данных DNS.

Хотя это облегчает вызов пользователя VoIP из IP и сетей PSTN, ENUM не является функцией VoIP и его не следует путать с обычной маршрутизацией VoIP, основанной на протоколах SIP, H.323 или IAX с единообразным идентификатором ресурса (URI).

Информация общего характера Наличие возможности набора телефонных номеров абонентами привычными способами считается одним из важных требований к технологиям, позволяющим объединять сети классической (PSTN) и VoIP-телефонии, кроме того, это требование распространяется и на новые мультимедийные услуги, работающие по IP. В связи с вышесказанным, возникает необходимость в едином универсальном личном идентификаторе для разных видов телекоммуникационных услуг. Один из подходов к решению задачи выбора такого идентификатора — технология ENUM (Electronic Number Mapping System — электронная система отображения номеров), разработанная IETF. В соответствии с ENUM, существующие телефонные номера стандарта E.164, протоколы и инфраструктура используются для получения непрямым образом доступа к различным видам услуг по единому личному идентификатору. ENUM позволяет осуществить «бесшовное» соединение сетей классической и IP-телефонии.

Детали системы Для использования услуги ENUM абоненту следует получить у регистратора следующие данные и полномочия:

1. Персональный (URI), используемый в сегменте сети, работающем по IP, подробнее см. ниже;

2. Номер телефона стандарта E.164, ассоциируемый с упомянутым выше URI, используемый в сегменте ТфОП;

3. Полномочия на изменение информации о переадресации и терминировании вызовов в записи NAPTR, доступной по персональному URI.

Это работает следующим образом: (1) Регистратор обеспечивает Подписчика (или Регистратора) именем домена, URI, которые будут использоваться, чтобы обратиться к DNS серверу, чтобы получить запись NAPTR, (2) персональный номер телефона E.164 (номер ENUM). Имя домена URI (1) — одно-двух-значно ассоциированное (взаимно-однозначно отображаемый) с E.164 номером подписчика ENUM (2). Наконец (3) запись NAPTR корреспондируется на [URI] подписчика содержащее предпочтения переадресации/завершения вызова подписчика.

Поэтому, если вызывающая сторона, находящаяся в сети PSTN, набирает вызываемую сторону номером ENUM, касаемый E.164 называемый номером вызываемой стороны, то номер будет переведен в шлюзе ENUM в соответствующих URI. Это URI будут использоваться для поиска и выборки получаемых записей NAPTR о желаемой вызываемой стороне относительно того, как вызов должен быть переадресован или закончен (либо на IP либо на PSTN-окончания) — так называемая информация доступа — который лицо, осуществляющее регистрацию (вызываемая сторона) определило, поместило этот выбор в 'запись NAPTR', «Имена авторизации указателей записей ресурсов» как определено в RFC 2915, типа адресов электронной почты, номера факса, личного веб-сайта, номер VoIP, номер мобильного телефона, систем голосовой почты, адресов IP-телефонии, веб-страницы, координат GPS, обход вызова или мгновенное сообщение. Поочередно, когда вызывающая сторона — сторона IP, Пользовательский Агент (UA), часть программного обеспечения номеронабирателя, позволяющая набирать номер E.164, кроме набора, UA конвертирует это в URI, используемое для поиске в шлюзе ENUM DNS и приносит запись NAPTR с получаемыми желаемыми данными вызываемой стороны о том, как вызов должен быть переадресован или закончен (снова, или на IP или на PSTN-окончания).

Вызов, использующий новый персональный номер E.164 (ENUM номер) к поиску в базе данных, следовательно является косвенным вызовом, поддерживаемый сервисом.

Для использования номеров E.164 с ENUM на IP стороне сети ITU ENUM определило специфическую зону, а именно «e164. arpa». RFC 3761 определяют, как любой ENUM номер, типа + 1 555 42 42 может быть преобразован в URI, заменяя порядок следования чисел, отделяя их точками и добавляя суффикс e164. arpa имея таким образом: 2.4.2.4.5.5.5.1.e164.arpa.

URI могут быть использованы, чтобы искать в DNS интернет-адреса для сервисов, типа SIP VoIP-телефонии. Записи NAPTR используются, чтобы установить персональные настройки переадресации/завершения вызовов абонентов. Поэтому целая система может 'транслировать' адреса E.164 в адреса SIP. Пример записи NAPTR:

$ORIGIN 2.4.2.4.5.5.5.1.e164.arpa. IN NAPTR 100 10 "u" "E2U+sip" "!^.*$!sip:[email protected]!" . IN NAPTR 102 10 "u" "E2U+mailto" "!^.*$!mailto:[email protected]!" .

В этом примере определено, что, если Вы хотите использовать сервис «E2U+sip», Вы должны в качестве адреса использовать sip: [email protected]. Регулярное выражение может использоваться телефонной компанией, чтобы легко назначить адреса для всех её клиентов. Например, если ваш номер — +15554242, вашим SIP-адрес является sip:[email protected]; если ваш номер +15551234, ваш SIP-адрес — sip:[email protected]. Следующий рисунок иллюстрирует, как ENUM работает представляя пример: Абонент А вызывает Абонента Б.

Пользовательский Агент с ENUM позволяющий оконечному устройству абонента, PBX, или Шлюзу, транслировать запрос о номере +34 98 765 4321 в соответствии с правилом, описанным в RFC 3761, в домен ENUM 1.2.3.4.5.6.7.8.9.4.3.e164.arpa. Запрос посылается Системе Доменных Имен (DNS), для выяснения ищется домен ENUM 1.2.3.4.5.6.7.8.9.4.3.e164.arpa. Запрос возвращает результат в форме так называемой Записи Ресурсов Указателей Авторитетных Имен NAPTR по RFC 3403. В примере выше приведён ответ в виде адреса, который может быть доступен в Интернете, используя VoIP протокол, SIP по RFC 3261. Приложение оконечного устройства теперь устанавливает коммуникационное соединение, а вызов маршрутизируется через Интернет.

Пользователь ENUM не замечает ничего из этой реверсии и поиска в базе данных DNS, поскольку это сделано автоматически и не на переднем плане, используя пользовательское программное обеспечение агента в компьютере, или в оконечном устройстве, или в PABX или в шлюзе. Например, когда пользователь набрал номер телефона в своём браузере, ENUM вызывает агента и указывает, какой информационный объект он ищет (адрес электронной почты, номер телефона, адрес сети и т. д.) в компьютере или в оконечном устройстве, номер конвертируется в имя домена. Его посылают серверам ENUM в Интернет, которые возвращают назад записи NAPTR, связанные с именами. Информация доступа и различные приоритеты, обозначенный для них, сохранены в них. Пользователю на его компьютер или оконечное устройство возвращают требуемый адрес. ENUM поэтому фактически функционирует как механизм того, чтобы перевести номер телефона в название домена с требуемым адресом или числом, связанным с ним, но без рассмотрения пользователя, как это выполнено, так же, как он даже не знает, что он использует DNS, что когда он делает вызов он осуществляется соединение через Интернет или что это осуществляется в телефонном коммутаторе.

Использование

Переадресация вызова через ENUM Один способ сделать переадресацию вызова через ENUM иллюстрирован на следующем рисунке. Вызывающий пользователь использует телефон, чтобы набрать номер другого абонента, который приводит к поиску через ENUM. DNS отвечает вызывающему, возвращая список с записями NAPTR для VoIP-коммуникаций, номеров телефонов и адресов электронной почты. После этого, будет сделана попытка установить соединение с абонентом, используя запись VoIP из этого списка. Если абонент не будет на связи, то следующий выбранной записью будет та, где подключение через PSTN или мобильный телефон. Если эта попытка будет также неудачна, то речевое сообщение будут выслано абоненту через перечисленных адрес электронной почты.

Поддомены ITU e164.arpa сначала делегируются на («регистрированный») регулирующую организацию, определяемую национальным правительствам страны имеющей соответствующий код страны, который далее делегирует зоны к телекоммуникационным провайдерам. Потом эти телефонные компании обычно отвечает за записи NAPTR. Некоторые страны предлагают позволить конечным пользователям регистрировать их собственные номера телефона через посредника, который не является их собственным телекоммуникационным оператором. Это считается хорошим предложением, поскольку VoIP — главный потребитель ENUM. Люди, которые используют сервисы VoIP c ENUM-поддержкой, могут набирать свой имеющийся номер и соединяться не по своей существующей телефонной линией, а на свой собственный VoIP-телефон непосредственно через Интернет, полностью обходя телефонную систему. То, когда они вызывают кого-то, кто не использует ENUM, вызов идёт полностью по Телефонной сети общего пользования или PSTN.

Также появился альтернативный бесплатный публичный сервис ENUM, такой как e164.org. В сервисе предполагалась проверка номера PSTN телефонным звонком с диктовкой PIN-кода. Конкуренцию зон ENUM можно отметить как полезную, сохраняющую цены на рынке VoIP низкими. Также доступны другие протоколы поиска ENUM, вроде sbXML. Это сервисы позиционируются, как обеспечивающие более быстрый и более лёгкий механизм трансляции номеров E.164 в SIP адреса.

Оборудование вызываемой стороны ENUM может также рассматриваться как оборудование вызываемой стороны. В основном, это — косвенное сервис вызова номера, разработанное, чтобы работать без стыков PSTN и VoIP, который основывается на большом количестве номеров E.164 чисел: миллиарды людей, знающих, как набирать телефонный номер.

Если вызываемый человек решил использовать ENUM, она/он опубликует номер ENUM и введёт (через ENUM NAPTR) его/её требования того, как вызов должен быть осуществлен. Это может быть единственный VoIP идентификатор, но наиболее вероятно это будет список того, как вызов должен быть переадресован на различные фиксированные линии, сотовые телефоны, секретарь или сервис голосовой почты, или по IP или в направлении сети PSTN. Это — выбор вызываемой стороны, чтобы выбрать из ENUM и также определить пожелания вызываемой стороны. по получению вызова.

Сегодня, когда пользователь совершает регулярные звонки по телефону, он должен определиться, как послать вызов другой стороне: через VoIP, фиксированную линию PSTN, сотовый телефон: ввести URI или набрать номер. С косвенным набором номера через ENUM это — выбор вызываемой стороны, чтобы поставить вопрос и получить его решение. Другая польза косвенного набора номера это свобода пользователя в изменении телефонного оператора, webpage, IMS, электронной почты или другого телекоммуникационного сервиса, которое он использует, без необходимости извещения об этом всех его партнёрам по контактны.

Наличие расширенного ENUM, имеющего различные профили, может автоматически изменить выбор вызываемой стороны как функция того, где он/она доступен. Это могло быть механизмом, чтобы автоматически переключать между сотовым телефоном и VoIP как самому удобному (или менее дорогостоящему) терминальному устройству.

Многообразие ENUM Говоря о ENUM, одним потенциальным источников сбоев, является на сегодня разнообразие представлений о месте ENUM. Весьма часто, разговор людей о ENUM действительно касается только к одному из следующего:

Общепользовательский ENUM: оригинальное видение ENUM как глобальной, общепользовательской каталогоподобной базы данных, содержащей в себе характеристики пользователей и делегирующей на уровне кода страны в домене e164.arpa. Это тоже относится к Пользовательским ENUM. Частный ENUM: поставщик услуг, оператор VoIP или Интернет-провайдер может использовать методики ENUM в пределах своих собственных сетей, таким образом DNS в сети для внутреннего пользования.