Рабочее предложение () — документ из серии пронумерованных информационных документов Интернета, содержащих технические спецификации и стандарты, широко применяемые во всемирной сети. Название «Request for Comments» ещё можно перевести как «заявка (запрос) на отзывы» или «тема для обсуждения». В настоящее время первичной публикацией документов RFC занимается IETF под эгидой открытой организации Общество Интернета (). Правами на RFC обладает именно Общество Интернета.
История Формат RFC появился в 1969 году при обсуждении проекта ARPANET, его предложил Стив Крокер и он же написал первый RFC. RFC 1 был опубликован 7 апреля 1969 г. и назывался «Host Software». Первые RFC распространялись в печатном виде на бумаге в виде обычных писем, но уже с декабря 1969 г., когда заработали первые сегменты ARPANET, документы начали распространяться в электронном виде.
Большинство ранних RFC было создано в Калифорнийском университете Лос-Анджелеса и .
С 1969 по 1998 гг. бессменным и единственным редактором RFC был Джон Постел. После его смерти Общество Интернета (ISOC) поручило редактирование и публикацию RFC Университета Южной Калифорнии.
Очерк истории RFC за 30 лет с 1969 по 1999 гг. представлен в RFC 2555.
Очерк истории RFC за 50 лет с 1969 по 2019 гг. представлен в RFC 8700.
Содержимое RFC Несмотря на название, запросы на отзывы RFC сейчас рассматриваются как стандарты Интернета (а рабочие версии стандартов обычно называют драфтами, от — черновой проект). Согласно RFC 2026, жизненный цикл стандарта выглядит следующим образом: Выносится на всеобщее рассмотрение интернет-проект (). Проекты не имеют официального статуса и удаляются из базы через шесть месяцев после последнего изменения. Если проект стандарта оказывается достаточно удачным и непротиворечивым, он получает статус предложенного стандарта (), и свой номер RFC. Наличие программной реализации стандарта желательно, но не обязательно. Следующая стадия — проект стандарта () — означает, что предложенный стандарт принят сообществом, в частности, существуют две независимые по коду совместимые реализации разных команд разработчиков. В проекты стандартов ещё могут вноситься мелкие правки, но они считаются достаточно стабильными и рекомендуются для реализации. Высший уровень — стандарт Интернета (). Это спецификации с большим успешным опытом применения и зрелой формулировкой. Параллельно с нумерацией RFC они имеют свою собственную нумерацию STD. Список стандартов имеется в документе STD 1 (сейчас это RFC 5000, но нумерация может измениться). Из более чем трёх тысяч RFC этого уровня достигли только несколько десятков. Многие старые RFC замещены более новыми версиями под новыми номерами или вышли из употребления. Такие документы получают статус исторических ()
Практически все стандарты Глобальной сети существуют в виде опубликованных заявок RFC. Но в виде документов RFC выходят не только стандарты, но также концепции, введения в новые направления в исследованиях, исторические справки, результаты экспериментов, руководства по внедрению технологий, предложения и рекомендации по развитию существующих Стандартов и другие новые идеи в информационных технологиях:
Экспериментальные () спецификации содержат информацию об экспериментальных исследованиях, интересных для интернет-сообщества. Это могут быть, например, прототипы, реализующие новые концепции. Информационные () RFC предназначены для ознакомления общественности, не являются стандартами и не являются результатом консенсуса или рекомендациями. Некоторые проекты, не получившие статуса Предложенного стандарта, но представляющие интерес, могут быть опубликованы как Информационные RFC. Лучший современный опыт (). Эта серия RFC содержит рекомендации по реализации стандартов, в том числе от сторонних организаций, а также внутренние документы о структуре и процедурах стандартизации.
Почти все стандарты разрабатываются под эгидой каких-либо научных или интернет-организаций (например W3C, IETF, консорциум Юникода, Интернет2).
Запросы на отзывы официально существуют только на английском языке. Строгих требований к оформлению нет. Встречаются RFC, написанные в строгом академическом стиле, иные — в дружеской неформальной манере. Существует традиция выпуска первоапрельских шуточных RFC, например, RFC 1149 рассказывает о передаче пакетов IP с помощью почтовых голубей.
Примеры популярных запросов на отзывы Номер RFCТемаRFC 768 RFC 768 UDPRFC 791 RFC 791 IPRFC 792 RFC 792 ICMPRFC 793 RFC 793 TCPRFC 821 SMTP, заменён RFC 2821RFC 822 Формат электронной почты, заменён RFC 2822RFC 826 Протокол разрешения адреса (ARP)RFC 894 RFC 894 IP по EthernetRFC 951 Протокол начальной загрузки (BOOTP)RFC 959 FTPRFC 977 NNTP — устаревший, дополнен RFC 2980 , заменён RFC 3977RFC 1034 DNS — концепцияRFC 1035 DNS — внедрениеRFC 1122 RFC 1122 Требования к хосту 1RFC 1123 RFC 1123 Требования к хосту 2RFC 1191 RFC 1191 Определение MTU путиRFC 1256 Обнаружение маршрутизатора в сетиRFC 1323 Высокопроизводительный протокол TCPRFC 1350 TFTPRFC 1403 Взаимодействие BGP и OSPFRFC 1459 RFC 1459 IRCRFC 1498 Архитектурная дискуссияRFC 1518 Присвоение адресов CIDRRFC 1519 Междоменная маршрутизацияRFC 1591 Структура доменных имёнRFC 1661 PPPRFC 1738 URLRFC 1771 BGP версии 4RFC 1772 Приложение BGPRFC 1789 Телефония по Интернет (заменён стандартами VoIP)RFC 1812 Требования к маршрутизаторам IPv4RFC 1855 Руководство по НетикетуRFC 1889 Транспорт реального времениRFC 1905 SNMPRFC 1907 SNMP версии 2RFC 1918 RFC 1918 «Сеть 10»RFC 1939 RFC 1939 Протокол POP версии 3 (POP3)RFC 2001 RFC 2001 Расширения производительности TCPRFC 2026 Процесс стандартизации в ИнтернетеRFC 2045 MIMERFC 2046 RFC 2047 RFC 2048 RFC 2049 RFC 2060 RFC 2060 IMAP версии 4 (IMAP4), заменён RFC 3501RFC 2131 DHCPRFC 2223 RFC 2223 Инструкции для авторов RFCRFC 2246 RFC 2246 SSL и TLSRFC 2231 Кодировка символовRFC 2328 OSPFRFC 2401 Архитектура безопасности протокола IP (IPsec)RFC 2453 RIPRFC 2516 RFC 2516 PPPoERFC 2525 Проблемы TCPRFC 2535 Безопасность DNSRFC 2581 RFC 2581 Контроль заторов в TCPRFC 2616 HTTPRFC 2637 PPTPRFC 2663 Трансляция сетевых адресовRFC 2766 NAT-PTRFC 2821 RFC 2821 SMTP, заменён RFC 5321RFC 2822 Формат электронной почтыRFC 2865 RADIUSRFC 2866 RFC 2866 Средства учёта RADIUSRFC 2960 SCTPRFC 2980 Общие расширения NNTP, дополняет RFC 977, заменён RFC 3977RFC 3010 NFSRFC 3031 Архитектура MPLSRFC 3066 Языковые тэгиRFC 3092 Этимология «Foo»RFC 3098 Ответственная реклама по электронной почтеRFC 3160 Гид по IETFRFC 3168 RFC 3168 ECNRFC 3261 SIPRFC 3501 IMAP версии 4 издание 1 (IMAP4rev1)RFC 3977 NNTP, заменяет RFC 977, дополняет RFC 2980
См. также
FYI
IETF W3C ISOC IEEE Первоапрельские RFC IEN
Ссылки
Официальные источники База данных RFC Запросы RFC на сайте IETF
Категория:Стандарты Интернета