IRDP (от или ) или RDISC (от — обнаружение маршрутизаторов) — протокол для компьютерных хостов для обнаружения присутствия и расположения маршрутизаторов в их локальной сети IPv4. Открытие маршрутизатора полезно для доступа к компьютерным системам в других нелокальных сетевых сетях. IRDP определен стандартом IETF RFC 1256, с протоколом управления доступом к Интернету (ICMP), на котором он основан, определен в IETF RFC 792. IRDP устраняет необходимость вручную настраивать информацию о маршрутизацииNetwork Protocols Handbook - Google Books. Сообщения об обнаружении маршрутизатора Чтобы включить обнаружение маршрутизатора, IRDP определяет два типа сообщений ICMPGuide to TCP/IP - Jeffrey L. Carrell, Laura Chappell, Ed Tittel, James Pyles - Google BooksIP-Based Next-Generation Wireless Networks: Systems, Architectures, and ... - Jyn-Cheng Chen, Tao Zhang - Google Books: Сообщение ICMP Router Solicitation отправляется с компьютера на любые маршрутизаторы в локальной сети, чтобы они сообщили о своём присутствии. Сообщение ICMP Router Advertisement Message отправляется маршрутизатором в локальной сети, чтобы объявить свой IP-адрес доступным для маршрутизации. Когда хост загружается, он отправляет приглашения на IP-адрес многоадресной рассылки 224.0.0.2. В ответ один или несколько маршрутизаторов могут отправлять рекламные сообщения. Если есть более одного маршрутизатора, хост обычно выбирает первое сообщение, которое он получает, и добавляет этот маршрутизатор в свою таблицу маршрутизации. Независимо от запроса, маршрутизатор может периодически отправлять рекламные сообщения. Эти сообщения не считаются протоколом маршрутизации, поскольку они не определяют путь маршрутизации, а только наличие возможных шлюзовTCP/IP Essentials: A Lab-Based Approach - Shivendra S. Panwar - Google Books. Расширения Стратегия IRDP использовалась при разработке протокола обнаружения соседних IPv6. Они используют сообщения ICMPv6, IPv6-аналог ICMP-сообщений. Обнаружение соседей регулируется стандартами IETF RFC 4861 и RFC 4862.
IRDP играет важную роль в мобильной сети через стандарт IETF RFC 3344. Это называется обнаружением агента MIPv4. См. также DHCP Примечания
Категория:Сетевые протоколы