Linphone () — кроссплатформенный программный клиент IP-телефонии в стандарте SIP с открытым исходным кодом, распространяемый по лицензии GNU GPL. Программа Linphone предназначена для организации аудио и видео-вызовов, а также обмена текстовыми сообщениями посредством Интернета.
SIP-клиент Linphone имеет простой многоязычный (в том числе русский) графический интерфейс, основанный на GTK, и может быть использован на всех наиболее распространённых операционных системах: Mac OS, Microsoft Windows (XP и Vista), Linux, а также на мобильных устройствах iPhone, BlackBerry и других, с поддержкой ОС Android. В Linux также доступны консольные утилиты: интерактивный клиент (linphonec) и утилита для управления Linphone с помощью аргументов командной строки (linphonecsh).
Возможности SIP-агент согласно RFC3261 Мгновенный обмен текстовыми сообщениями на основе протокола SIMPLE Аудиокодеки: G.711, GSM-FR, Speex, AMR и iLBC, а также HD: G.722 и Opus Видеокодеки: H.263, MPEG4, theora, H.264, AV1 и H.265, VP8 DTMF методом SIP INFO или RFC4733 (RFC2833) Статусы пользователей (Presence и BLF) на основе SIP SUBSCRIBE/NOTIFY Интеграция с LDAP, поддержка CardDAV ENUM Поддержка IP-адресов IPv6 Преодоление NAT посредством STUN
В приложении применяются методики обеспечения безопасности и шифрования (все функции являются опциональными, т.е. отключаемы): Безопасная цифровая аутентификация: md5 / SHA256 и TLS-сертификаты для клиента End-to-end шифрование для медиа-трафика: SRTP, zRTP and SRTP-DTLS End-to-end шифрование для обмена текстовыми сообщениями с использованием Linphone Instant Messaging Encryption (LIME) Алгоритм CRYSTALS-Kyber.
Дополнительные функции Адресная книга Дополнения-плагины Возможность работы из консоли и интеграции в любой графический интерфейс
Скриншоты
См. также Сравнение программ для IP-телефонии
Примечания
Ссылки www.linphone.org — сайт программы www.Belledonne-Communications.com — сайт компании Belledonne Communications, осуществляющей разработку и коммерческую поддержку программы
Категория:Программы мгновенного обмена сообщениями Категория:Кроссплатформенное программное обеспечение Категория:IP-телефония Категория:Свободное программное обеспечение для видеоконференции Категория:Программное обеспечение для macOS Категория:Программное обеспечение для Android Категория:Программное обеспечение для Linux Категория:Программное обеспечение для Windows Категория:Программное обеспечение мобильных телефонов Категория:Программное обеспечение с лицензией GNU GPL