Statuskoder
Nedan finns en lista över svarskoder för HTTP, och fraser till koderna som kort ska beskriva vad statuskoden innebär. De flesta av dessa statuskoder är specificerade av RFC 2616, medan några är ostandardiserade statuskoder som också används på webben.
Den första siffran i statuskoden anger vilken typ av svar som skickas.
I texten används orden server och klient. Klienten kan bland annat vara en webbläsare eller en sökmotor, och servern är den dator som klienten ansluter till.
1xx Informerande
Förfrågan togs emot, men har inte slutförts. Få webbservrar och webbläsare hanterar dessa koder.
100: Continue 101: Switching Protocols
2xx Lyckad förfrågan
Förfrågan togs emot, förstods och accepterades.
200: OK 201: Created 202: Accepted 203: Non-Authoritative Information 204: No Content 205: Reset Content 206: Partial Content
3xx Vidarekoppling
Ännu en handling, som till exempel en vidarekoppling eller ett val av språk, måste utföras för att slutföra förfrågan.
300: Multiple Choices 301: Moved Permanently 302: Moved Temporarily (HTTP/1.0) 302: Found (HTTP/1.1) 303: See Other (HTTP/1.1) 304: Not Modified Betyder att sidan inte har förändrats sedan senaste besöket. 305: Use Proxy Många HTTP-klienter (som till exempel Mozilla och Internet Explorer) hanterar inte svar med denna statuskod korrekt. 306: (oanvänd men reserverad) 307: Temporary Redirect Objektet har tillfälligt flyttats, men använd den gamla adressen nästa gång. 308 Permanent Redirect (RFC 7538) Objektet har flyttats permanent, uppdatera eventuella bokmärken
4xx Klientfel
Förfrågan har en felaktig syntax eller kan inte utföras/fullföljas.
400: Bad Request 401: Unauthorized Se Basic authentication scheme och Digest access authentication (båda sidorna är på engelska). Mer specifik än 403. 402: Payment Required Den här statuskoden kan användas när betalning krävs för att komma åt en sida. Det finns dock ingen standard för hur det här ska fungera. 403: Forbidden Servern har en sådan sida men vill inte lämna ut den. 404: Not Found Sidan finns inte 405: Method Not Allowed 406: Not Acceptable 407: Proxy Authentication Required 408: Request Timeout 409: Conflict 410: Gone Filen har funnits men har tagits bort permanent och bör inte förfrågas igen. 411: Length Required Information som skickades till servern, till exempel genom en POST-förfrågan, kunde inte behandlas eftersom längden på informationen inte angavs. 412: Precondition Failed 413: Payload Too Large (RFC 7231) Tidigare Request Entity Too Large R 414: Request-URI Too Long 415: Unsupported Media Type Klienten frågar efter en mediatyp som filen inte kan ges som. 416: Requested Range Not Satisfiable 417: Expectation Failed 418: I'm a teapot Denna statuskod definierades 1998 i RFC 2324, Hyper Text Coffee Pot Control Protocol, som ett aprilskämt av IETF och förväntas inte att implementeras i faktiska HTTP-servrar. Den förekommer ändå och det har förekommit protester mot förslag att ta bort koden.
5xx Serverfel
Servern misslyckades med att slutföra en till synes giltig förfrågan.
500: Internal Server Error Internt fel på själva webbservern 501: Not Implemented Servern stödjer inte en funktion som efterfrågades av klienten. 502: Bad Gateway 503: Service Unavailable Tillfälligt avbrott 504: Gateway Timeout 505: HTTP Version Not Supported 509: Bandwidth Limit Exceeded Denna statuskod skickas när en webbsida har använt mer trafik än vad som tillåts. Den används av många webbservrar men är egentligen ingen officiell statuskod för HTTP.
Se även HTTP URL HTML XHTML World Wide Web Consortium
Källor W3Cs officiella specifikation för HTTP-statuskoder
HTTP-statuskoder, lista