Internet Group Management Protocol (IGMP) är ett nätverksprotokoll som används för att hantera medlemskapet i IP-multicastgrupper. IGMP används av IP-noder och intilliggande multicast-routrar för att etablera medlemskap(er) i multicast-grupper. Den är en grundläggande del av IP-multicastspecifikationen, och liknar ICMP:s funktion i "vanliga" IP-anslutningar. IGMP kan användas för online-video och spel, och tillåter en effektivare användning av nätverksresurser. Dock gör IGMP vissa datorintrång möjliga,Spoofed IGMP report denial of service vulnerability.Fragmented IGMP packet may promote "Denial of Service" attack.IGMP Security Problem Statement and Requirements .Microsoft Security Bulletin MS06-007: Vulnerability in TCP/IP Could Allow Denial of Service (913446) . och brandväggar tillåter vanligtvis användare att stänga av IGMP-protokollet om det inte behövs.
IGMP har tre meddelanden:
Membership Query Membership Report Leave Group
IGMP specificeras i RFC-dokumenten RFC 866, RFC 988, RFC 1054, RFC 1112, RFC 1812, RFC 2236, RFC 2113, och RFC 3376.
Källor
Kategori:Internet Kategori:Nätverksskiktsprotokoll