V-card, i marknadsföringssyfte skrivet vCard, är ett standard filformat för elektroniska visitkort. V-card är ofta knutna till e-postmeddelanden, men kan utbytas på andra sätt, exempelvis på internetsidor. De kan innehålla namn och adressuppgifter, telefonnummer, e-postadresser, webbadresser, logotyper, fotografier och till och med ljudklipp.

Exempel på en V-card-fil Följande är ett exempel på en V-card-fil med innehåll om en person:

V-card 2.1: BEGIN:VCARD VERSION:2.1 N:Gump;Forrest FN:Forrest Gump ORG:Bubba Gump Shrimp Co. TITLE:Shrimp Man TEL;WORK;VOICE:(111) 555-1212 TEL;HOME;VOICE:(404) 555-1212 ADR;WORK:;;100 Waters Edge;Baytown;LA;30314;United States of America LABEL;WORK;ENCODING=QUOTED-PRINTABLE:100 Waters Edge=0D=0ABaytown, LA 30314=0D=0AUnited States of America ADR;HOME:;;42 Plantation St.;Baytown;LA;30314;United States of America LABEL;HOME;ENCODING=QUOTED-PRINTABLE:42 Plantation St.=0D=0ABaytown, LA 30314=0D=0AUnited States of America EMAIL;PREF;INTERNET:[email protected] REV:20080424T195243Z END:VCARD

V-card 3.0: BEGIN:VCARD VERSION:3.0 N:Gump;Forrest FN:Forrest Gump ORG:Bubba Gump Shrimp Co. TITLE:Shrimp Man TEL;TYPE=WORK,VOICE:(111) 555-1212 TEL;TYPE=HOME,VOICE:(404) 555-1212 ADR;TYPE=WORK:;;100 Waters Edge;Baytown;LA;30314;United States of America LABEL;TYPE=WORK:100 Waters Edge\nBaytown, LA 30314\nUnited States of America ADR;TYPE=HOME:;;42 Plantation St.;Baytown;LA;30314;United States of America LABEL;TYPE=HOME:42 Plantation St.\nBaytown, LA 30314\nUnited States of America EMAIL;TYPE=PREF,INTERNET:[email protected] REV:20080424T195243Z END:VCARD

Egenskaper

V-card använder följande egenskapstyper: *FN, *N, NICKNAME, *PHOTO, *BDAY, *ADR, *LABEL, *TEL, *EMAIL, *MAILER, *TZ, *GEO, *TITLE, *ROLE, *LOGO, *AGENT, *ORG, CATEGORIES, *NOTE, PRODID, *REV, SORT-STRING, *SOUND, *URL, *UID, *VERSION, CLASS, *KEY.

Name Beskrivning Anteckning N Namn En strukturerad representation av namnet på den person, plats eller sak i samband med vCard objektet. FN Formaterat namn Den formaterade namn strängen i samband med vCard objektet PHOTO Fotografi En bild eller foto av personen BDAY Födelsedag Födelsedag för personen ADR Leveransadress Den fysiska adressen för vCard objektet LABEL Adress Etikett för fysisk leverans till den person / objekt i samband med vCard-objektet TEL Telefon Den kanoniska nummer strängen för ett telefonnummer för vCard objektet EMAIL E-post E-postadressen för vCard objektet MAILER E-post Program (Optional) Vilket e-postprogram som användaren använder TZ Tidszon Information om vilken tidszon vCard objektet använder GEO Global Positioning Latitud and longitud för vCard objektet TITLE Titel Anger jobbtitel, funktionell ställning eller funktion för vCard-objektet inom en organisation (VP forskning och utveckling) ROLE Yrke yrke eller affärsverksamhet kategori för vCard objektet inom en organisation (till exempel direktör) LOGO Logo En bild eller grafik av logotypen för organisationen som vCard-objektet tillhör AGENT Agent Information om en annan person som agerar på uppdrag av vCard objektet. Exempelvis administratör, assistent eller sekreterare ORG Företag eller avdelningsnamn Namnet och valfritt enhet (er) av organisationen i samband med vCard objektet. Denna fastighet är baserat på X.520 Organisationens namn attribut och X.520 organisationsenhet attribut NOTE Notering Anger kompletterande information eller en kommentar som är associerad med vCard REV Senast ändrad Kombination av kalendern datum och klockslag för den senaste uppdateringen till vCard objektet SOUND Ljud Som standard, om denna egendom inte är grupperade med andra egenskaper som det anges uttalet av Formaterad Namn egendom vCard objektet. URL URL En URL till Internet-plats som kan användas för att få information i realtid om vCard-objektet UID Unique Identifier Anger ett värde som motsvarar en ihållande, globalt unik identifierare i samband med objektet VERSION Version Version av vCard-specifikationen KEY Public Key Den offentliga krypteringsnyckeln samband med vCard objektet Dessutom, eftersom V-card förstärker RFC-2425, en standard för nummerupplysning, stöds även följande egenskapstyper: SOURCE, NAME, PROFILE, BEGIN, END.

Referenser

Externa länkar Internet mail Consortium - Personal Data Interchange vCard: The Electronic Business Card (Version 2.1) vCard 2.1 specification (Sept-18-1996) Representing vCard Objects in RDF/XML, W3C Note 22 February 2001 hCard specification vCard implementations notes and bug reports vCard proposed errata RFC 2425 - A MIME Content-Type for Directory Information RFC 2426 - vCard MIME Directory Profile RFC 2739 - Calendar Attributes for vCard and LDAP RFC 4122 - UUID URN namespace (could be used for UID type) RFC 4770 - vCard Extensions for Instant Messaging IETF vCardDAV working group

Kategori:Filsystem