Починаючи з 1989 року кожне 1 квітня Internet Engineering Task Force публікує один або декілька жартівливих документів RFC, продовжуючи традицію, почату з червня 1973 року, коли був випущений RFC під назвою ARPAWOCKY. Наступний список включає також декілька гумористичних RFC, виданих в інші числа.
Список першоквітневих RFC Дата RFC Назва Автор Розмір Стан Коментарі 22 червня 1973 RFC 527 ARPAWOCKY R. Merryman, Каліфорнійський університет, Сан-Дієґо Стилізація під Люїса Керролла. 1 квітня 1978 RFC 748 Telnet randomly-lose option M.R. Crispin 2741 байт Unknown Пародія на стиль документування протоколів TCP/IP. 1 грудня 1985 RFC 968 Twas the night before start-up V.G. Cerf Стилізація під відомий вірш К. К. Мура «Ніч перед Різдвом». 1 квітня 1989 RFC 1097 Telnet subliminal-message option B. Miller 5490 байт Unknown 1 квітня 1990 RFC 1149 Стандарт передачі IP-дейтаграм за допомогою поштових голубів (Standard for the transmission of IP datagrams on Avian Carriers) D. Waitzman 3329 байт Experemental Оновлений у RFC 2549 1 квітня 1991 RFC 1216 Gigabit Network Economics and Paradigm Shifts Poorer Richard, професор Kynikos 8130 байт Informational 1 квітня 1991 RFC 1217 Memo from the Consortium for Slow Commotion Research (CSCR) Вінтон Серф 11079 байт Informational 1 квітня 1992 RFC 1313 Today’s Programming for KRFC AM 1313 Internet Talk Radio C. Partridge 5444 байт Informational 1 квітня 1993 RFC 1437 The Extension of MIME Content-Types to a New Medium N. Borenstein, M. Linimon 13356 байт Informational 1 квітня 1993 RFC 1438 Internet Engineering Task Force Statements Of Boredom (SOBs) A. Lyman Chapin, C. Huitema 3044 байт Informational 1 квітня 1994 RFC 1605 SONET to Sonnet Translation Приписано Вільяму Шекспіру, насправді робота Крейга Партріджа 4451 байт Informational 1 квітня 1994 RFC 1606 Використання протоколу IPv9 з історичної точки зору (A Historical Perspective On The Usage Of IP Version 9) J. Onions 8398 байт Informational 1 квітня 1994 RFC 1607 Погляд з XXI століття (A view from the 21st century) Вінтон Серф 28165 байт Informational 1 квітня 1995 RFC 1776 The Address is the Message 2051 байт Informational Without content, would we need information security? 1 квітня 1996 RFC 1924 A Compact Representation of IPv6 Addresses R. Elz 10409 байт Informational 1 квітня 1996 RFC 1925 The Twelve Networking Truths R. Callon 4294 байт Informational 1 квітня 1996 RFC 1926 An Experimental Encapsulation of IP Datagrams on Top of ATM J. Eriksson 2969 байт Informational 1 квітня 1996 RFC 1927 (Suggested Additional MIME Types for Associating Documents) C. Rogers 5254 байт Informational 1 квітня 1997 RFC 2100 Іменування майданчиків тенет (The Naming of Hosts) J. Ashworth 4077 байт Informational 1 квітня 1998 RFC 2321 RITA — The Reliable Internetwork Troubleshooting Agent A. Bressen 12302 байт Informational 1 квітня 1998 RFC 2322 Management of IP numbers by peg-dhcp K. van den Hout, A. Koopal, R. van Mook 12665 байт Informational 1 квітня 1998 RFC 2323 IETF Identification and Security Guidelines A. Ramos 9257 байт Informational 1 квітня 1998 RFC 2324 Гіпертекстовий протокол управління кавоваркою (Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0)) L. Masinter 19610 байт Informational 1 квітня 1998 RFC 2325 Definitions of Managed Objects for Drip-Type Heated Beverage Hardware Devices using SMIv2 M. Slavitch 12726 байт Informational 1 квітня 1999 RFC 2549 IP за допомогою поштових голубів з QoS (IP over Avian Carriers with Quality of Service) D. Waitzman 9519 байт Informational Оновлення документу RFC 1149 1 квітня 1999 RFC 2550 Проблема Y10k (Y10K and Beyond) S. Glassman, M. Manasse, J. Mogul 28011 байт Informational 1 квітня 1999 RFC 2551 The Roman Standards Process — Revision III S. Bradner 28054 байт Informational 1 квітня 2000 RFC 2795 The Infinite Monkey Protocol Suite (IMPS) S. Christey 42902 байт Informational 1 квітня 2001 RFC 3091 Протокол генерації числа пі (Pi Digit Generation Protocol) H. Kennedy Informational 1 квітня 2001 RFC 3092 Етимологія слова «Foo» (Etymology of «Foo») D. Eastlake 3rd, C. Manros, Ерік Реймонд Informational 1 квітня 2001 RFC 3093 Протокол розширення брандмауера (Firewall Enhancement Protocol (FEP)) M. Gaynor, S. Bradner Informational 1 квітня 2002 RFC 3251 Електрика за допомогою IP (Electricity over IP) B. Rajagopalan 18941 байт Informational 1 квітня 2002 RFC 3252 Binary Lexical Octet Ad-hoc Transport H. Kennedy Informational 1 квітня 2003 RFC 3514 Прапорець безпеки у IPv4 (Диявольський біт) (The Security Flag in the IPv4 Header (Evil Bit)) S. Bellovin Informational 1 квітня 2004 RFC 3751 Omniscience Protocol Requirements S. Bradner Informational 1 квітня 2005 RFC 4041 Requirements for Morality Sections in Routing Area Drafts A. Farrel Informational 1 квітня 2005 RFC 4042 Формати ефективного трансформування Юнікода UTF-9 і UTF-18 (UTF-9 and UTF-18 Efficient Transformation formats of Unicode) M. Crispin Informational