Netflow — мережевий протокол, призначений для обліку мережевого трафіку, розроблений компанією Cisco Systems. Є фактично промисловим стандартом і підтримується не тільки обладнанням Cisco, а й багатьма іншими пристроями (зокрема, Juniper і Enterasys). Також існують вільні реалізації для UNIX-подібних систем.
Аналізуючи дані, надані NetFlow, адміністратор мережі може визначити джерело та призначення трафіку, клас обслуговування та причини перевантаження.
Існує кілька версій протоколу, найпоширенішими з яких на 2011 рік є версії 5 і 9. На основі версії 9 також розроблено відкритий стандарт під назвою IPFIX (Internet Protocol Flow Information eXport - експорт інформації про потоки IP)Information Model for IP Flow Information Export. .
Архітектура
NetFlow для передавання даних про трафік колектора використовує UDP або SCTP. Як правило, колектор слухає порт 2055, 9555 або 9995.
Для збору інформації про трафік за протоколом NetFlow потрібні такі компоненти: Сенсор. Збирає статистику щодо трафіку, який через нього проходить. Зазвичай це L3-комутатор або маршрутизатор, хоча можна використовувати й окремі сенсори, які отримують дані шляхом дзеркалення порту комутатора. Колектор. Збирає одержувані від сенсора дані і поміщає їх у сховище. Аналізатор. Аналізує зібрані колектором дані і формує придатні для читання людиною звіти (часто у вигляді графіків).
Див. також аналоги sFlow (RFC 3176, Brocade Networks) NetStream (3Com, H3C, Huawei) Cflow (Alcatel-Lucent) Jflow & cflowd (Juniper Networks)
Примітки
Посилання Специфікація протоколу версії 9. Сторінка протоколу на сайті Cisco Systems. PMACCT — вільна реалізація сенсора для UNIX-систем (також підтримує sFlow і IPFIX). Flow-tools — вільна реалізація колектора NetFlow. FlowViewer — вільна реалізація аналізатора NetFlow. NetFlow/FloMA: Pointers and Software Provided by SWITCH. — One of the most comprehensive list including all the open source and research works. FloCon — The Annual Conference put on by CERT/CC dealing with NetFlow and other flow analysis works. Basic NetFlow information on the Cisco Site RFC3334 — Policy-Based Accounting RFC3954 — NetFlow Version 9 RFC3917 — Requirements for IP Flow Information Export (IPFIX) RFC3955 — Candidate Protocols for IP Flow Information Export (IPFIX) RFC5101 — Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow Information (IPFIX) RFC5102 — Information Model for IP Flow Information Export RFC5103 — Bidirectional Flow Export Using IP Flow Information Export RFC5153 — IPFIX Implementation Guidelines RFC5470 — Architecture for IP Flow Information Export RFC5471 — Guidelines for IP Flow Information Export (IPFIX) Testing RFC5472 — IP Flow Information Export (IPFIX) Applicability RFC5473 — Reducing Redundancy in IP Flow Information Export (IPFIX) and Packet Sampling (PSAMP) Reports Using Netflow to store re-aggregated inbound and outbound flows AppFlow specifications and standards track discussion