BPDU (Bridge Protocol Data Unit) — фрейм (одиниця даних) протоколу управління мережевими мостами, IEEE 802.1d, базується на реалізації протоколу STP (Spanning Tree Protocol). Використовується для виключення можливості виникнення петель в мережах передачі даних при наявності в них багатозв'язкової топології. Використовуючи один фізичний або логічний зв'язок як основного, BPDU утримує один з доступних вторинних зв'язків у режимі бездіяльності (очікування). Таким чином, корисний трафік передається тільки по одному з доступних зв'язків. При порушенні функціонування одного з каналів (що легко спостерігається відсутністю проходження через нього повідомлень 802.1d) вторинний канал що очікує автоматично включається в роботу, забезпечуючи безперервність зв'язності в мережі.
Фрейм BPDU має такі поля:
Ідентифікатор версії протоколу STA (2 байти). Комутатори повинні підтримувати одну і ту ж версію протоколу STA; Версія протоколу STP (1 байт); Тип BPDU (1 байт). Існує 2 типу BPDU — конфігураційний і сповіщення про реконфігурації; Прапори (1 байт); Ідентифікатор кореневого комутатора (8 байт); Відстань до кореневого комутатора (4 байти); Ідентифікатор комутатора (8 байт); Ідентифікатор порту (2 байти); Час життя повідомлення (2 байти). Вимірюється в одиницях по 0.5 сек, служить для виявлення застарілих повідомлень; Максимальний час життя повідомлення (2 байти). Якщо кадр BPDU має час життя, що перевищує максимальний, то кадр ігнорується комутаторами; Інтервал hello (2 байт), інтервал через який надсилаються пакети BPDU; Затримка зміни станів (2 байти). Мінімальний час переходу комутатора в активний стан.
Див. також IEEE 802
Посилання
Cisco home page for the Spanning-Tree protocol family (discusses CST, MISTP, PVST, PVST+, RSTP, STP) Educational explanation of STP www.cisco.com STP article in the Wireshark wiki Includes a sample PCAP-file of captured STP traffic.
IEEE Standards ANSI/IEEE 802.1D-2004 standard , section 17 discusses RSTP (Regular STP is no longer a part of this standard. This is pointed out in section 8.) ANSI/IEEE 802.1Q-2005 standard , section 13 discusses MSTP RFCs RFC 2674–1999, proposed standard, Definitions of Managed Objects for Bridges with Traffic Classes, Multicast Filtering and Virtual LAN Extensions RFC 1525–1993, — SBRIDGEMIB, proposed standard, Definitions of Managed Objects for Source Routing Bridges RFC 1493–1993 — BRIDGEMIB, draft standard, Definitions of Managed Objects for Bridges Spanning Tree Direct vs Indirect Link Failures — CCIE Study