CalDAV - це інтернет протокол за допомогою якого клієнтське календарне ПЗ отримує інформацію про заплановані події з віддаленого сервера. Розширює WebDAV специфікацію та використовує iCalendar формат даних. Повна специфікація протоколу наведена в RFC 4791. Протокол дозволяє одночасний доступ декільком клієнтам до інформації, що забезпечує спільне планування та обмін інформацією. Протокол підтримується великою кількістю серверного та клієнтського ПЗ. Розширення CalDAV для автоматизованого планування наведено в стандарті RFC 6638.
Приклад Приклад запита та відповідіhttps://tools.ietf.org/html/rfc4791#section-7.10.1 7.10.1. Example: Successful CALDAV:free-busy-query REPORT:
Запит:REPORT /bernard/work/ HTTP/1.1 Host: cal.example.com Depth: 1 Content-Type: application/xml; charset="utf-8" Content-Length: xxxx
<?xml version="1.0" encoding="utf-8" ?> <C:free-busy-query xmlns:C="urn:ietf:params:xml:ns:caldav"> <C:time-range start="20060104T140000Z" end="20060105T220000Z"/> </C:free-busy-query>
Відповідь:HTTP/1.1 200 OK Date: Sat, 11 Nov 2006 09:32:12 GMT Content-Type: text/calendar Content-Length: xxxx
BEGIN:VCALENDAR VERSION:2.0 PRODID:-//Example Corp.//CalDAV Server//EN BEGIN:VFREEBUSY DTSTAMP:20050125T090000Z DTSTART:20060104T140000Z DTEND:20060105T220000Z FREEBUSY;FBTYPE=BUSY-TENTATIVE:20060104T150000Z/PT1H FREEBUSY:20060104T190000Z/PT1H END:VFREEBUSY END:VCALENDAR
Примітки
Посилання Сайт, присвячений CalDAV CalConnect - консорціум з планування та ведення календаря Каталог WebDAV ресурсів Байкал - легкий CalDAV+CardDAV сервер з відкритим початковим кодом
Стандарти RFC RFC 2616 – HTTP RFC 3744 – WebDAV Access Control Protocol RFC 4791 – CalDAV RFC 4918 – WebDAV RFC 5545 – iCalendar RFC 5546 – iTIP