L'Internet Architecture Board (IAB) és un comitè de l'Internet Engineering Task Force (IETF) i un òrgan assessor de l'Internet Society (ISOC). Les seves responsabilitats inclouen la supervisió arquitectònica de les activitats de l'IETF, la supervisió i apel·lació del procés d'estàndards d'Internet i el nomenament de l'editor de sol·licituds de comentaris (RFC). L'IAB també és responsable de la gestió dels registres de paràmetres del protocol de l'IETF.
Història L'organisme que finalment es va convertir en l'IAB va ser originalment l' Internet Configuration Control Board (ICCB). Va ser creat per Vint Cerf el 1979 mentre treballava a l'Agència de Projectes de Recerca Avançats de Defensa (DARPA) del Departament de Defensa dels Estats Units.
El 1983, l'ICCB va ser reorganitzat per Barry Leiner, successor de Cerf a DARPA, al voltant d'una sèrie de grups de treball que consideraven diferents aspectes tècnics de la interconnexió. El grup reorganitzat es va anomenar Internet Activities Board (IAB).
L'IAB es va fixar set objectius principals per al període de 1989 a 1990. Aquests eren, a saber:
Estabilitat operativa Serveis d'usuari Coexistència OSI Instal·lacions de prova Seguretat Fent-se gran Aconseguir rapidesa
Finalment es va convertir en l' Internet Architecture Board, sota l'ISOC, el gener de 1992, com a part de la transició d'Internet d'una entitat del govern dels Estats Units a una entitat pública internacional.
Responsabilitats L'IAB és responsable de:
Supervisió arquitectònica dels protocols i procediments d'Internet Enllaç amb altres organitzacions en nom de l'Internet Engineering Task Force (IETF) Revisió de les apel·lacions del procés d'estàndards d'Internet Gestió de documents d'estàndards d'Internet (la sèrie RFC) i assignació de valors de paràmetres de protocol Confirmació del president de l'IETF i dels directors d'àrea de l'IETF Selecció del president del Grup de Treball de Recerca d'Internet (IRTF) Actuant com a font d'assessorament i orientació per a la Societat d'Internet.
En la seva tasca, l'IAB s'esforça per:
Assegurar-se que Internet sigui un mitjà de comunicació fiable que proporcioni una base tècnica sòlida per a la privadesa i la seguretat, especialment a la llum de la vigilància omnipresent, Establir la direcció tècnica per a un Internet que permeti connectar-se a milers de milions de persones més, doni suport a la visió d'un Internet de les coses i permeti que les xarxes mòbils prosperin, tot mantenint les capacitats bàsiques que han estat la base de l'èxit d'Internet. Promoure l'evolució tècnica d'un Internet obert sense controls especials, especialment aquells que dificulten la confiança a la xarxa.
Activitats Les activitats de l'IAB inclouen:
Tallers
Taller sobre els impactes de la COVID-19 a la xarxa, 2020 Taller Explorant la sinergia entre l'agregació de continguts i l'ecosistema editorial 2019 Taller sobre expectatives de disseny vs. realitat de desplegament en el desenvolupament de protocols 2019 Documents de posició: Taller DEDR Taller de Sistemes de Nomenclatura Explícita d'Internet (EName) 2017 Taller d'actualització de programari de l'Internet de les coses (IoTSU) 2016 Taller d'Interoperabilitat Semàntica de la IoT 2016 Taller sobre la gestió de xarxes de ràdio en un món xifrat (MaRNEW) 2015 Taller de Coordinació de la Resposta a Atacs a Escala d'Internet (CARIS) 2015 Convocatòria de ponències Ordre del dia: Taller de coordinació de la resposta a atacs a escala d'Internet (CARIS) Taller de l'IAB sobre l'evolució de la pila en una Internet Middlebox (SEMI) 2015 Taller del W3C/IAB sobre l'enfortiment d'Internet contra la vigilància omnipresent (STRINT) 2014 Taller de l'IAB sobre l'adopció i la transició de la tecnologia d'Internet (ITAT) 2013 Taller IAB / IRTF sobre control de congestió per a la comunicació interactiva en temps real 2012 Taller sobre control de congestió: documents de posició Agenda i materials del taller de control de congestió Taller d'Interconnexió d'Objectes Intel·ligents amb Internet 2011 Tutorial sobre la interconnexió d'objectes intel·ligents amb Internet Documents de posició Agenda Taller de privadesa a Internet 2010 Presentacions de diapositives Actes del Taller de Privacitat a Internet de l'IAB/W3C/ISOC/MIT Actes de la reunió Documents de posició acceptats Taller d'encaminament i direccionament 2006 Taller sobre trànsit no desitjat 2006 Taller d'Internet sense fils de l'IAB 2000
Programes tècnics i grups de suport administratiu
Programa d'editors de RFC: Comitè de supervisió de la sèrie RFC (RSOC) Programa de Desenvolupament Futur de l'Editor de RFC Programa de planificació plenaria Programa del Model d'Amenaces d'Internet (model-t) Grup IETF-IANA Programa d'Evolubilitat, Desplegabilitat i Mantenibilitat (EDM) Programes conclosos Programa de seguretat Programa de privacitat Ressenyes de privadesa Enquesta de privadesa IPv6 Programa de privadesa i seguretat Programa de noms i identificadors Programa de supervisió d'enllaç Programa de coordinació de la UIT-T Programa d'evolució de la pila IP Evolució de la IP Programa d'Internacionalització Comitè de Supervisió dels Registres de Protocols de l'IETF (IPROC) Programa d'eines i processos de l'IAB Serveis d'Emergència
Citacions i confirmacions de l'IAB
Grup de Coordinació Comunitària (CCG): Russ Housley (2017–2021), Barry Leiba (2017–2021), Tim Wicinski (2018–2022) Grup de Coordinació de la Transició de l'Administració de l'IANA (ICG): Russ Housley, Lynn St Amour Enllaç amb la Junta Directiva de l'ICANN: Harald Alvestrand: (2018–actualitat) Comitè de Revisió de l'Evolució de la Zona Arrel de la ICANN (RZERC): Tim (abril, 2020–2021) ICANN NomCom: Peter Koch, 2020 Grup d'enllaç tècnic de la ICANN (TLG): Warren Kumari (2019–2021), Petr Špaček (2020–2022)
Responsabilitats Les responsabilitats actuals de l'IAB inclouen:
Supervisió arquitectònica: l'IAB supervisa i ocasionalment fa comentaris sobre aspectes de l'arquitectura dels protocols i procediments de xarxa utilitzats per Internet. Supervisió i apel·lació del procés d'estàndards: L'IAB supervisa el procés utilitzat per crear estàndards d'Internet. L'IAB actua com a junta d'apel·lació per a les queixes sobre l'execució inadequada del procés d'estàndards, actuant com a òrgan d'apel·lació respecte a una decisió d'estàndards de l'Internet Engineering Steering Group (IESG). Sèrie de sol·licituds de comentaris: l'IAB és responsable de la gestió editorial i la publicació de la sèrie de documents de sol·licituds de comentaris (RFC). Autoritat d'Assignació de Números d'Internet: Juntament amb la Corporació d'Internet per a l'Assignació de Noms i Números (ICANN), l'IAB és responsable de l'administració de l'assignació de valors dels paràmetres del protocol IETF per part de l'Autoritat d'Assignació de Números d'Internet (IANA). Enllaç extern: l'IAB actua com a representant dels interessos de l'IETF en relacions d'enllaç amb altres organitzacions relacionades amb estàndards i altres qüestions tècniques i organitzatives rellevants per a Internet a tot el món. Assessorament a la Societat d'Internet: L'IAB actua com a font d'assessorament i orientació per a la junta directiva i els funcionaris de l'ISOC pel que fa a qüestions tècniques, arquitectòniques, procedimentals i (si escau) polítiques relacionades amb Internet i les seves tecnologies facilitadores. Confirmació del Grup Directiu d'Enginyeria d'Internet: L'IAB confirma el president de l'IETF i els directors d'àrea de l'IESG, a partir de les nominacions proporcionades pel Comitè de Nominacions de l'IETF. President del Grup de Treball de Recerca d'Internet: L'IAB selecciona un president de l'IRTF per a un mandat renovable de dos anys.
RFC1087 – Ètica, Internet i l'ascens a la modernitat L'IAB pren una postura formal sobre què constitueix un ús correcte d'Internet en el seu memoràndum de 1989, RFC 1087: "Ètica i Internet". Presenten la seva versió contemporània d'Internet, que en aquell moment es trobava en les seves etapes inicials, servint principalment com a eina per a la comunicació de la recerca a la comunitat científica, i identifiquen l'ús d'aquest Internet com un "privilegi".
L'IAB proclama aleshores com a il·lícita qualsevol activitat que:
busca obtenir accés no autoritzat als recursos d'Internet, interromp l'ús previst d'Internet, malgasta recursos (persones, capacitat, ordinador) a través d'aquestes accions, destrueix la integritat de la informació informàtica compromet la privadesa dels usuaris.
RFC 2850 - Charter of the Internet Architecture Board La RFC 2850 estableix l'estructura i el propòsit de l'IAB. La RFC especifica el següent:
Membres de l'IAB: l'IAB té 13 membres, un dels quals és el president de l'Internet Engineering Task Force (IETF). Aquests membres són nomenats per mandats de 2 anys. El paper de l'IAB: L'IAB serveix per proporcionar supervisió arquitectònica per als procediments d'Internet i per supervisar el procés de creació d'estàndards d'Internet, incloses les apel·lacions. A més, l'IAB actua com a enllaç amb la Internet Society (ISOC) per assessorar sobre qüestions arquitectòniques i tècniques. Organització de l'IAB: Els 13 membres de l'IAB trien un membre per exercir de president de l'IAB durant un mandat d'un any. No hi ha límit al nombre de mandats que pot exercir el president. El director executiu de l'IAB és escollit pel president. L'IAB també té la facultat de designar el president de l'Internet Research Task Force (IRTF) durant un mandat de dos anys. Presa de decisions: en la majoria de situacions, l'IAB pretén arribar a decisions unànimes sobre els assumptes. Quan això no és possible, l'IAB ha d'arribar a un consens d'almenys 7 membres abans de prendre mesures. Transparència i confidencialitat: L'IAB fa que totes les reunions siguin públiques en línia i també publica regularment RFC per tal que les seves conclusions siguin generalment accessibles. En algunes situacions, però, la informació confidencial s'exclou per motius de privadesa.
RFC 2026 - El procés d'estàndards d'Internet El procés d'estàndards d'Internet és una activitat de la Societat d'Internet que està organitzada i gestionada en nom de la comunitat d'Internet per l'Internet Architecture Board (IAB) i l'Internet Engineering Steering Group (IESG). El procés d'estàndards d'Internet s'ocupa de tots els protocols, procediments i convencions que s'utilitzen a o per Internet. El procés de creació d'un estàndard d'Internet és senzill: una especificació passa per un període de desenvolupament i diverses iteracions de revisió per part de la comunitat d'Internet i revisió basada en l'experiència, s'adopta com a estàndard per l'organisme apropiat (ja sigui l'IAB o l'IESG) i es publica. Cada versió diferent d'una especificació relacionada amb estàndards d'Internet es publica com a part de la sèrie de documents "Sol·licitud de comentaris" (RFC). Aquesta sèrie d'arxiu és el canal de publicació oficial per als documents d'estàndards d'Internet i altres publicacions de l'IESG, l'IAB i la comunitat d'Internet. El procés complet d'estàndards d'Internet s'especifica mitjançant una RFC, concretament la RFC 2026.
RFC 8980 - Taller sobre expectatives de disseny vs. realitat de desplegament en el desenvolupament de protocols El taller RFC 8980 es va celebrar el febrer de 2021, on l'IAB va debatre diversos temes relacionats amb els protocols de seguretat, com ara:
Estàndards de correu electrònic, que presumien que molts proveïdors funcionaven de manera majoritàriament descoordinada, però que han vist tant una consolidació significativa del mercat com una necessitat de coordinació per defensar-se contra el correu brossa i altres atacs. Els mecanismes de coordinació i defensa centralitzada s'escalen millor per a les grans entitats; això ha impulsat una consolidació addicional.