Az adatkapcsolati réteg () az OSI-modell második rétege, a csatorna adategységei a keretek. A réteg alapvető feladata a hibamentes adatátvitel biztosítása a gépek között, vagyis a hibás, zavart, tetszőlegesen kezdetleges átviteli vonalat hibamentessé transzformálja az összeköttetés idejére. Az adatokat adatkeretekké () tördeli, majd sorrendben továbbítja, ezután a fogadó féltől a nyugtázókeretet () fogadja, amennyiben az adatok hibátlanul megérkeztek. Feladatai közé tartozik a hibajavítást és forgalomszabályozás. Két pont között a kommunikációs áramkörök hibáznak, véges az adatátviteli sebességük és késleltetést is okoznak. Az osztott csatornához való hozzáféréssel a közeghozzáférés-vezérlő alréteg (MAC) foglalkozik, a hibajavításról pedig a logikai kapcsolatvezérlési alréteg (LLC) gondoskodik.

Leírása hálózati rétegnek nyújtott szolgáltatás nyugtázatlan összekötés nélküli szolgálat nyugtázott összekötés nélküli szolgálat nyugtázott összekötés alapú szolgálat keretezés (kezdet, vég) karakterszámlálás kezdő és végkarakterek kezdő és végbitek fizikai rétegbeli kódolásértés hibavédelem (error control) pontosan egyszeri megérkezés (időzítők, számlálók kezelése), ismétléssel javítás forgalom szabályozás (flow control) adó gyors, vevő lassú

Hibajelzés és javítás Hibajavító kódolás: n = m + r (adat és ellenőrző bitek) Kódszavak Hamming távolság, d távolság (különbözőségek száma), d egybites hiba kell az egymásba való átmenethez: d hibát jelezni d+1 távolságú kód kell, d hibát javítani 2d+1 kód kell. 1 bites javító minta: (n+1) x 2m = 2n, n = m + r, (m+r+1) <= 2r, m=7, r=? 11<= 24 11. bitet az 1,2,8 bit ellenőriz Ellenőrző bitek: 1, 2, 4, 8 pozícióban, 3=1+2 , 5=1+4 , 11=1+2+8 ellenőrzőbit páros Hibajelző kódok

Paritás bit, kereszt és hossz paritás bitek Polinom-kód (cyclic redundancy code, CRC)

M (X), rn G(X) generátor polinom foka, m+r, T(x)=M(x)+ Or(x) T(x) / G(x) = 0 8 bithez CRC-16 felismer minden egybites és kétbites hibát, minden páratlan számú hibás bitet tartalmazó hibát, valamint minden 16 vagy kevesebb bitnyi csoportos hibát, a 17 bites csoportok 99,997, a 18 vagy több bitesek 99,998 százalékát.

Elemi adatkapcsolati protokollok Szimulátor elemei, deklarációk C nyelven. Frame = bind, request, ack, info. Korlátozás nélküli szimplex protokoll Szimplex megáll és vár protokoll Szimplex protokoll zajos csatornához.

Csúszóablakos protokoll Az adatra ráültetésként (piggybacking) küldjük a nyugtát n bites mezőben van egy sorszám (0 * 2n-1 között), küldött keret sorszáma Lényege: az adási ablak hossza, amely meghatározza, hogy hány keretet tudunk folyamatosan adni a nyugtázás bevárása nélkül 1-4 méretű csúszóablakos protokoll n visszalépést alkalmazó protokoll (go back n) Szelektív ismétlési (selective repeat) a vevő elfogadja és puffereli a sérült keret után jövő további kereteket, időzítés lejárta után az adó elküldi ezt a keretet.

Példák adatkapcsolati protokollokra HDLC (High-level Data Link Control) magas szintű adatkapcsolati vezérlés IBM SDLC, ANS, ADCCP, CCITT LAP-B, ISO HDLC bitalapú, bitbeszúrással transzparens, duplex, kétirányú adatátvitel, kellően hatékony, klasszikussá vált, stabil adatkapcsolati protokoll. 01111110 keret, cím, vezérlés, adat, ellenőrzőösszeg CRC-CCITT, 01111110 Internet adatkapcsolati rétege (otthoni PC telefonon keresztül) Slip (Serial Line IP) soros vonali IP kapcsolat 1984, RFC 1055, RFC 1144, fő probléma, hogy nem csinál hibajelzést és javítást, csak az IP-t támogatja, előre kell ismerni az IP címeket, nem végez azonosítást, nem Internet szabvány. PPP (Point-to-Point Protocol) IETF az RFC 1661, 1662, 1663-ban definiáltatta, keretez, LCP az adatkapcsolati protokoll, NCP a hálózati interfész protokoll. HDLC-szerű csak karakteresen oldja meg az algoritmusokat. ATM adatkapcsolati rétege (TC alréteg). Csak a cellafej ellenőrzött (5 bájt = 32 bit vezérlés + 8 bit ellenőrző bit) HEC (Header Error Control) javítja az egybites hibákat több bites hibát csak jelez. Cella-továbbítás aszinkron esetben azonnal, szinkron esetben az időzítésnek megfelelően. Szinkronizálás, n darab egymás utáni jó HEC (Header Error Control), vadászat, előszinkron, szinkron állapot a rosszindulatú "HEC" elkerülésére (adatok közé HEC), az adatbiteket összekeverik. Az adatszóró hálózatok esetén felmerül a kérdés az adatkapcsolati réteget illetően: miképp szabályozni az osztott csatornához való hozzáférést? Ezzel a problémával az adatkapcsolati rétegnek egy speciális alrétege, a közeg-hozzáférési réteg alréteg foglalkozik.

Közeg-hozzáférési módszerek További elnevezések: véletlen hozzáférésű csatorna (random access channel, multiaccess channel) többszörös elérési csatorna. A LAN-oknál az adatkapcsolati réteg két alrétegre bomlik, a felső az LLC, (Logical Link Control), amely hasonlít az előző fejezet adatkapcsolati feladatához, az alsó a MAC (Media Access Control), amely a közeg használatának vezérléséért felelős (igaziból a fizikai réteghez tartozik). Néhány többszörös hozzáférésű protokollok ALOHA, 1970, Hawaii, Norman Abramson (pure ALOHA). Poisson eloszlást feltételezve 18% az elérhető legjobb csatornakihasználtság. Réselt ALOHA, 1972, Roberts, 37%, a rés elején van a sok ütközés (slotted ALOHA)

Vivőjel érzékelés (carrier sense protocols) 1-perzisztens CSMA (Carrier Sense Multiple Access) vár amíg szabad a csatorna, azután ad, ha ütközik, véletlen idő után 1 valószínűséggel ad. nem-perzisztens CSMA, ha foglalt a csatorna, nem figyel folyamatosan, véletlen ideig vár (nem mohó) p-perzisztens CSMA, réselt csatorna esetén, szabad rés esetén p valószínűséggel adni kezd

CSMA ütközésérzékeléssel CSMA/CD (Collision Detection), sérült keretek küldésének megszakításával időt takarít meg, a versenyes periódusban van főként az ütközés. Ütközés érzékelésénél leállás. Ütközésmentes protokoll

Bit térkép protokoll N darab 1 bites időrés lefoglalásos (reservation) protokollal Bináris visszaszámlálás, sorrendben a legnagyobb helyértékű biteket jelentő állomások az adó joggal rendelkezők, a kisebbek kilépnek Korlátozott versenyes, a résekért csoportok versenyeznek (csoport változó) Adaptív fabejárás, a rések a fa szerkezetével kapcsolatosak Hullámhosszosztásos protokoll. A WDMA (Wavelength Division Multiple Access), két csatorna, egy keskeny az állomás felé érkező vezérlőjeleknek, egy széles az adatkeretek továbbítására.

Vezeték nélküli LAN protokollok MACA (Multiple Access with Collision Avoidance) 1990, Karl, IEEE 802.11 alapján, RTS darabszám, CTS darabszám MACAW, 1994, Bharghavan, javított MACA, ACK, torlódási információk megosztása. Digitális cellarádió GSM (Global System for Mobile Communications, EU), vonalkapcsolt, 900 MHz, DCS 1800 Mhz-en az újabb, 5000 oldal, 124 × 200 KHz × 2 csatorna FDM-mel, 8 különböző összeköttetés TDM-mel, réselt ALOHA 8 adatkeret alkot egy TDM keretet és 26 TDM keretből áll össze 120 ms multikeret. 51 részt tartalmaz multikeretet is használnak.

Források

Hálózati kislexikon

Kategória:Internet Kategória:Hálózati protokollok