RTCP ( — протокол управления передачей в реальном времени) — протокол, используемый совместно с RTP. Протокол описан в RFC 3550,RFC 3550, RTP: A Transport Protocol for Real-Time Applications, H. Schulzrinne, S. Casner, R. Frederick, V. Jacobson, The Internet Society (Июль 2003). RTCP базируется на периодической передаче управляющих пакетов всем участникам сессии, используя тот же механизм рассылки, что и для пакетов данных.

Протокол RTCP используется для передачи информации о задержках и потерях медиа-пакетов, джиттер-буфере, уровне звукового сигнала. Также передаются метрика качества сигнала (Call Quality Metrics) и Echo Return Loss.

Определены следующие типы сообщений RTCP: SR - Sender Report - отчёт отправителя по отправленным медиа-пакетам RTP RR - Receiver Report - отчёт получателя по полученным медиа-пакетам RTP SDES - элементы описания источника, включая cname BYE - Отмечает прекращение участия в группе APP - Специфические функции приложения

В рекомендации RFC 3611 определено также сообщение XR - Extended Report, которое позволяет отправлять большее число параметров, по сравнению со стандартными отчётами, а именно:

Время получения пакета Порядковые номера потерянных пакетов Порядковые номера повторяющихся пакетов Ожидаемое время доставки Задержка с момента приема последнего отчета RTCP Receiver Report Общая статистика медиа-пакетов Оценка VoIP - направления (MOS и R Factor - параметр характеризующий качество сигнала)

Шифрование RTCP

Существует вариант протокола RTP c шифрованием Secure Real-time Transport Protocol (SRTP) для обеспечения безопасной передачи данных. И так как RTP тесно связан с RTCP (Real-Time Control Protocol), который может использоваться, чтобы управлять сессией RTP, у SRTP также есть родственный протокол, названный Secure RTCP (или SRTCP). SRTCP обеспечивает те же самые функции, связанные с безопасностью в RTCP, для той же функциональности SRTP в RTP.

Протокол SRTCP описан в RFC 3711 об SRTP в главе 3.4.

SRTCP добавляет 3 новых обязательных поля "SRTCP index", "encrypt-flag" и "authentication tag" и опциональное поле MKI в описание пакета RTCP.

Использование SRTP или SRTCP является необязательным при использовании RTP или RTCP, но даже если SRTP/SRTCP используются, все дополнительные возможности (такие как шифрование и установление подлинности) опциональны и могут быть включены или выключены. Единственное исключение — функция аутентификации сообщений, которая обязательна при использовании SRTCP.

Для шифрования медиа потока (в целях конфиденциальности голосового соединения), SRTP вместе с SRTCP стандартизируют использование только единственного шифра, AES, который может использоваться в двух режимах, превращающих изначально блочный шифр AES в потоковый шифр.

См. также RTP SRTP ZRTP RTSP

Примечания

Ссылки Транспортный протокол реального времени RTCP

Категория:Протоколы транспортного уровня Категория:Протоколы VoIP